W3C home > Mailing lists > Public > public-owl-dev@w3.org > April to June 2012

Parser error in loading an Ontology

From: Mahmood2.Ahmad <Mahmood2.Ahmad@live.uwe.ac.uk>
Date: Tue, 26 Jun 2012 08:53:58 +0000
To: "public-owl-dev@w3.org" <public-owl-dev@w3.org>
Message-ID: <6473DF3703AC694685B9C07875F6DCA006B1FFDE@DB3PRD0702MB132.eurprd07.prod.outlook.com>
Hello,

I am a newbie in use of OWL API. I am trying to load an Ontology which is a merger of three Ontologies. I tried to first load one of them adapting an example program from OWL API page: http://owlapi.sourceforge.net/2.x.x/documentation.html, just to realize that it displayed classes and sub-classes in the Ontology.

I learnt from the error message that OWL API tried every parser to parse the Ontology but failed. The errors that I got were very similar to the ones that were shared by another questioner and I read the response as well. However, the remedy was not discussed. The problem identified in this previous problem on the list was 'xml' being redefined.

My error message is as follows:

The following parsers were tried:
1) RDFXMLParser
2) OWLXMLParser
3) OWLFunctionalSyntaxOWLParser
4) TurtleOntologyParser
5) OWLOBOParser
6) KRSS2OWLParser
7) ManchesterOWLSyntaxOntologyParser


Detailed logs:
--------------------------------------------------------------------------------
Parser: RDFXMLParser
org.semanticweb.owlapi.rdf.syntax.RDFParserException: [line=1:column=7] Expecting rdf:RDF element.

--------------------------------------------------------------------------------
Parser: OWLXMLParser
org.xml.sax.SAXParseException: The reference to entity "uid" must end with the ';' delimiter.

--------------------------------------------------------------------------------
Parser: OWLFunctionalSyntaxOWLParser
Encountered " <FULLIRI> "<html> "" at line 1, column 1.
Was expecting:
    "Ontology" ...
     (Line 0)

--------------------------------------------------------------------------------
Parser: TurtleOntologyParser
uk.ac.manchester.cs.owl.owlapi.turtle.parser.ParseException: Encountered " <PNAME_NS> "owl-ontologies.com: "" at line 3, column 12.
Was expecting:
    "." ...


--------------------------------------------------------------------------------
Parser: OWLOBOParser
org.coode.owlapi.obo.parser.TokenMgrError: Lexical error at line 1, column 7.  Encountered: "\n" (10), after : ""

--------------------------------------------------------------------------------
Parser: KRSS2OWLParser
de.uulm.ecs.ai.owlapi.krssparser.ParseException: Encountered " ">" "<html> "" at line 1, column 1.
Was expecting:
    <EOF>


--------------------------------------------------------------------------------
Parser: ManchesterOWLSyntaxOntologyParser
Encountered '<html>' at line 1 column 1.  Expected either 'Ontology:' or 'Prefix:' (Line 1)

[END OF ERROR MESSAGE]

(I do not know if this is the right end to attempt correcting the problem .......) The OWLXMLParser suggests there is an entity name 'uid', but I do not find any such entity in neither the merged Ontology nor the constituent ontologies.

Any suggestion, I'll appreciate greatly.
Very grateful,

Mahmood Ahmad
Received on Tuesday, 26 June 2012 11:59:00 GMT

This archive was generated by hypermail 2.3.1 : Wednesday, 27 March 2013 09:32:59 GMT