W3C home > Mailing lists > Public > public-owl-dev@w3.org > January to March 2007

Re: SubObjectPropertyChain question

From: Holger Knublauch <holger@topquadrant.com>
Date: Mon, 12 Mar 2007 09:06:51 -0700
Message-ID: <45F57A9B.50601@topquadrant.com>
To: public-owl-dev@w3.org

>> <owl11:PropertyChain>
>>  <owl11:members rdf:parseType="Collection">
>>       <owl11:ObjectProperty rdf:ID="p1"/>
>>        ...
>>   </owl11:members>
>>   <rdfs:subPropertyOf rdf:resource="#p"/>
>> </owl11:PropertyChain>
> This works fine with me except that I don't think the 
> <rdfs:subPropertyOf/> should be used.  The reason is the same as I 
> raised before, it will suggest <owl:PropertyChain> is a rdf:Property, 
> which is not, because the chain is a composition of properties.  Use 
> another property name will make it separate cleanly.

I very much support this (or a similar) solution.  The current 
rdfs:subPropertyOf syntax breaks RDF compatibility (and is rather 
difficult to read).  An explicit chain axiom class would be better.

Received on Monday, 12 March 2007 16:07:02 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:58:14 UTC