Would it make sense to rename IceController to IceAgent?

I like the name "IceAgent" a little more, and it matches more closely the
phrasing used in RFC 5245.

Along with that, would it make sense to require having an IceAgent to
create an IceTransport?

partial interface RTCIceAgent {

   RTCIceTransport createTransport(

IceOptions optional, optional int index);

   RTCIceTransport createAssociatedTransport(

RTCIceTransport transport);

};

I realize this is counter to our general model of creating objects directly
and not have factories, but since it's generally a mistake to have more
than one IceTransport without an IceController/IceAgent due to freezing,
having IceAgent/IceController be a factory might make sense.  It also has
the benefit that all transports come from the same place.


Thoughts?

Received on Wednesday, 30 July 2014 00:33:49 UTC