W3C home > Mailing lists > Public > public-opentag@w3.org > May 2012

Re: distinguishing between 'description URLs' and 'interface URLs'

From: Paul Michelotti <pmichelotti@citytechinc.com>
Date: Wed, 9 May 2012 10:05:31 -0500
Message-ID: <CAGwQP9iu1JQqESMK4B9DpHbyxUccUKL6zjkK9dae17zCU+0+pA@mail.gmail.com>
To: Michiel de Jong <michiel@unhosted.org>
Cc: Marcos Caceres <w3c@marcosc.com>, public-opentag@w3.org
This seems a reasonable distinction at a high level and I definitely agree
with the goal of unambiguously naming things.  Just a couple thoughts.

> for the other two i would say:
> 2) the string X is the "URL of an interface to" the object Y
> 3) the string X is the "URL of a description of" the object Y

I disagree with the wording of 2.  Given this specific example, the most we
would be able to say is "the string X is the URL of an interface to a
mailbox which object Y owns (or is somehow associated with)" (unless when
you say "object Y" you are referring to the mailbox and not the "user").

for non-web entities, or in secondary documents:
> - URN
> - interface-URL
> - description-URL

for web entities:
> - retrieval-URL
> - interaction-URL

For web entities the separation of retrieval-URL and interaction-URL is
somewhat artificial and it's necessity and value I imagine would be
application specific.  It is entirely possible that a retrieval-URL and an
interaction-URL will be the same URL.  For example,
http://www.example.com/docs/exampledoc.html may be a retrieval-URL for a
particular document resource representation, but may also act as an
interaction-URL for updating the document resource.


On Wed, May 9, 2012 at 8:49 AM, Michiel de Jong <michiel@unhosted.org>wrote:

> On Wed, May 9, 2012 at 1:55 PM, Marcos Caceres <w3c@marcosc.com> wrote:
> > Just to handle the simple case, is it possible to change the data to
> make it more descriptive (then you don't need to deal so much with the URI
> semantics)? Like:
> >
> > <person
> >   email="some@email.com"
> >   description="http://about.me/description"
> > />
> >
> > Or is that something you are already doing?
> So say 'description' instead of 'description-URI'? that wouldn't work.
> 'description' already means 'description'. :) If you make a method
> called setDescription(string) and then make its behaviour to be
> setDescriptionUri(string) then you've made a misnomer.
> in the case of email this is less obvious, because we (wrongly)
> already often use 'email' to mean 'email address'. although sometimes
> we also use 'email' to mean 'email message'. but the real meaning of
> 'email' is 'email, the medium'. so in terms of variable naming, i
> would say what you proposed there is pretty close, but no cigar. i
> would instead do:
> <person
>   emailAddress="some@email.com"
>   descriptionUri="http://about.me/description"
> />
> just to avoid confusion. as a programmer you can't be careful and
> precise enough when naming your variables IMO.

Paul Michelotti
312.673.6433 x 171
Received on Wednesday, 9 May 2012 21:28:16 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:35:46 UTC