W3C home > Mailing lists > Public > public-mwts@w3.org > September 2008

Results of running perf tests on a few mobile browsers (Was: [minutes] Tuesday 2nd Sep teleconf)

From: Dominique Hazael-Massieux <dom@w3.org>
Date: Fri, 12 Sep 2008 15:44:03 +0200
To: public-mwts <public-mwts@w3.org>
Message-Id: <1221227043.19890.470.camel@localhost>

Le mercredi 03 septembre 2008 à 15:05 +0200, Wilhelm Joys Andersen a
écrit :
> Here are some:
>   http://www2.webkit.org/perf/sunspider-0.9/sunspider.html

Failed to run on blazer/palm treo 650 - just displays a question mark.
On Netfront/PSP, I manage to get until the "start now" page, but it
doesn't seem to run anything.
I ran it on the android emulator (webkit-based browser), it displays
"3d-cube", and then seems to stop.
It didn't run on Opera Mini, but I didn't expected it to.
It crashed the OpenWave simulator -but then it's running through wine on
Linux, so it doesn't mean much, although I don't expect it would give
much on it either.

>   http://dromaeo.com/

The page loads in Blazer, but doesn't run the tests - at least it
doesn't display the individual progress bars.
Same on Netfront/PSP.
On Androit/Webkit, the individual progress bars showed up, and the
estimated time too, but I didn't seem to actually run the tests.

>   http://en.wikipedia.org/wiki/IBench (must be installed locally)

I couldn't run that one since it requires IIS.

>   http://people.opera.com/~pettern/performance-1.html

Didn't do anything on Blazer, nor netfront.
It ran on Android/Webkit (at ~ FPS 15, for 5 dots).

>   http://people.opera.com/~pettern/performance-2.html

Didn't do anything on Blazer, nor netfront.
It ran on Android/Webkit (at ~ FPS 17, for 5 dots).

>   http://code.google.com/apis/v8/run.html

The page loads on Blazer, but doesn't do anything.
On Netfront, it displays "completed 86%" and then fails with a memory
error, and no subscores displayed.
On Android, completed 57% of the tests and then apparently stopped (with
score 1 to Richards, DeltaBlue, Crypto).

>   http://nontroppo.org/timer/kestrel_tests/
->
http://nontroppo.org/timer/progressive_raytracer.html
Doesn't work on Blazer (interface not displayed properly).
Doesn't seem to work on Netfront (although the interface did appear
correctly).
Works on Android (took 69 s for Basic Render)

http://nontroppo.org/timer/Mesh_Transform.html
didn't complete on blazer - browser kept trying to receive data?
didn't show a results on netfront.
Android: 10573 ms.

http://nontroppo.org/timer/3D_cube.html
Blazer: doesn't work
Netfront: doesn't work
Android: seems to work, but requires "moving mouse of the window" which
is rather difficult :)

http://nontroppo.org/timer/jsspeed2.html
Blazer: didn't seem to work (didn't complete)
Netfront: only the DOM speed tests worked, and the calculation of total
duration didn't work
Android: works (total duration 12824ms)

http://nontroppo.org/timer/Hixie_DOM.html
Blazer: didn't work
Netfront: works (total elapsed time 42...ms)
Android: works (total elapsed time 12297ms)

http://nontroppo.org/timer/animation_tests/table.html
Blazer: stopped after loading ~900K of data due to memory error
Netfront: failed due to memory error
Android: works (12733ms) - but not clear that it did fully work, since
the image looked truncated

(note: the test (and the following 3 Ones) displays first "test failed
to run", and changes it later on to "loading test" which is quite
confusing on a slow device/connection)

http://nontroppo.org/timer/animation_tests/canvas.html
Blazer: didn't complete and blocked the browser (browser commands no
longer reactive - but that might have been the accumulation of
scriptings beforehand, since I experienced a reboot of my phone shortly
afterwards)
Netfront: failed due to memory error
Android: works (67777ms)

http://nontroppo.org/timer/animation_tests/div1.html
Blazer: stopped after loading ~1.1MB of data.
Netfront: failed due to memory error
Android: works (93647 ms)

http://nontroppo.org/timer/animation_tests/div2.html
Blazer: stopped after loading ~255KB of data
Netfront: failed due to memory error
Android: works (109790 ms)

>   http://people.mozilla.com/~schrep/image12.html
Blazer: didn't work (didn't even display the image)
Netfront: didn't work (didn't even display the image)
Android: didn't work (image displayed, but controls inoperative - also,
sliders unusable without a mouse?)

> http://mootools.net/slickspeed/
Blazer: didn't work
Netfront: failed due to memory error
Android: works (best results obtained with Dojo and JQuery).

Dom
Received on Friday, 12 September 2008 13:45:18 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 12 September 2008 13:45:19 GMT