[mediacapture-image] Rename videoStreamTrack to track

beaufortfrancois has just created a new issue for 
https://github.com/w3c/mediacapture-image:

== Rename videoStreamTrack to track ==
As we already pass a `track` MediaStreamTrack object into the 
constructor, it would be nicer to call it `track` as well and not 
`videoStreamTrack`.

```diff
[Constructor(MediaStreamTrack track)]
interface ImageCapture {
-    readonly attribute MediaStreamTrack videoStreamTrack;
+    readonly attribute MediaStreamTrack track;
    readonly attribute MediaStream      previewStream;
    Promise<PhotoCapabilities> getPhotoCapabilities();
    Promise<void>              setOptions(PhotoSettings? 
photoSettings);
    Promise<Blob>              takePhoto(PhotoSettings? 
photoSettings);
    Promise<ImageBitmap>       grabFrame();
};

Please view or discuss this issue at 
https://github.com/w3c/mediacapture-image/issues/87 using your GitHub 
account

Received on Wednesday, 5 October 2016 09:55:36 UTC