Re: Screen sharing function name

On 2/9/15 12:28 PM, Peter Thatcher wrote:
> I don't think "sharing" really has anything to do with it.  We don't 
> call it "getCameraShare" or "getMicrophoneShare", for example.

But that's what it is. Like the doorhangers say, they're requests for 
the user to "share" their "camera and microphone with" the app.

While getSharedUserMedia() would be accurate, it's redundant, because 
the user is an implicit participant (either the subject or joint 
observer of the experience being filmed), so getUserMedia() works.

Not so for getSystemMedia(). There's no relationship with a user 
implicit in that statement. It sounds like a call that doesn't involve a 
user at all (computer-generated diagnostic media streams and test patterns)?

So I think we need to put "share" or "user" in there, since that's the 
important point of this API:

     getSharedScreenMedia() or getUsersScreenMedia() ?

> However, since this ultimately an API for developers, calling it what 
> developers would expect might make sense.  If the answer to "how do I 
> get a screenshare track?" is "call getScreenShare()", that might make 
> sense.  Plus, I think no one would ever say "what does getScreenShare 
> do?", because it would be pretty obvious.  So, "getScreenShare" may 
> have merit in that regard.

That might work. Others have mentioned we should try to follow the 
template get(x|y)Media(), and I think that makes sense, regardless of 
any love for that way of phrasing.

.: Jan-Ivar :.

Received on Wednesday, 11 February 2015 15:42:40 UTC