Re: Output device enumeration

I do wonder if getSources should have a slight extension, and if that 
would be sufficient?

What if we returned:

{
   { 1234, "video", "First camera"},
   { 2345, "audio", "Headset microphone"},
   { 3697, "audioOut", "Headset speakers"}
}

We could even extend this to say:

{
   { 1234, "video", "First camera", group=42},
   { 7654, "audio", "First camera microphone", group=42},
   { 2345, "audio", "Headset microphone", group=17},
   { 3697, "audioOut", "Headset speakers", group=17}
}

to indicate that the headset microphone and speaker are part of the 
samedevice.

In that case, the name "getSources" is clearly a misnomer; renaming it 
to "getDevices" should be No Big Deal.

Since we already have rules for access to the labels of getSources, we 
can carry that through to output devices, not confusing the programmer 
further; if we add the getPermissions call so that you can get 
permission without opening a camera, we have the basis for letting the 
UA decide how much prompting is worth doing.

Simplest solution that satisfies the stated requirements?

Received on Friday, 6 September 2013 08:27:53 UTC