Re: [Bug 23263] New: Add output device enumeration to GetSources

On 11/26/2013 01:31 AM, Cullen Jennings (fluffy) wrote:
> I discussed this with several developers and WebRTC Expo and they all like it. Some folks from Priologic and others want in addition to the things you have in the array to also add: facing , max resolution, HW codecs available,
I think we're over the edge into what gets returned by getCapabilities() 
on the device here.
>
> Are the labels always in english?

The labels are intended to be whatever makes sense for that OS/hardware 
platform. Most of the time, for browsers that are not integrated into 
the platform, the browser will have no control over the strings, so 
can't provide translations; the OS may have facilities for relabeling 
devices, but I think that's out of scope for this API.

>
> What is the permission model around what an app can access?

I thought I'd keep the "group" together with the "id" attribute as 
"available before being granted permissions", but don't feel strongly 
about that.

>
>
> On Sep 23, 2013, at 6:47 AM, Harald Alvestrand <harald@alvestrand.no> wrote:
>
>> This has been out for review for 6 days. People were supportive of it before, it does not seem to be controversial now.
>>
>> If it remains uncontroversial, we'll tell the editors to add it.
>>
>>        Harald
>>
>>
>> On 09/17/2013 03:55 PM, bugzilla@jessica.w3.org wrote:
>>> https://www.w3.org/Bugs/Public/show_bug.cgi?id=23263
>>>
>>>              Bug ID: 23263
>>>             Summary: Add output device enumeration to GetSources
>>>             Product: WebRTC Working Group
>>>             Version: unspecified
>>>            Hardware: All
>>>                  OS: All
>>>              Status: NEW
>>>            Severity: normal
>>>            Priority: P2
>>>           Component: Media Capture and Streams
>>>            Assignee: public-media-capture@w3.org
>>>            Reporter: harald@alvestrand.no
>>>                  CC: public-media-capture@w3.org
>>>
>>> This is the formalization of a proposal made on the mailing list on Sept 9.
>>>
>>> Proposal: Add output devices to the GetSources call, and add a "group"
>>> attribute for device grouping.
>>>
>>> Rules for attribute visibility should be as for GetSources.
>>>
>>> Example output:
>>>
>>> {
>>>    { 1234, "video", "First camera", group=42},
>>>    { 7654, "audio", "First camera microphone", group=42},
>>>    { 2345, "audio", "Headset microphone", group=17},
>>>    { 3697, "audioOut", "Headset speakers", group=17}
>>> }
>>>
>>> Here, the headset microphone and speaker are part of the same device.
>>>
>>> WebIDL changes:
>>>
>>> - Change name of call to GetDevices
>>> - Rename "SourceInfo" dictionary to "DeviceInfo"
>>> - Add an attribute of type DOMString called "group"
>>> - Add "audioOut" and "videoOut" as legal values for the "kind" attribute
>>>
>>

Received on Tuesday, 26 November 2013 07:49:19 UTC