MediaStreamOptions should be a dictionary

In the spec [1], and given the example 2.2:

> 2.2 Examples
> 
> <script>
> navigator.getUserMedia({"audio": true, "video": false}, gotAudio);
> function gotAudio(stream) {
>   // ... use 'stream' ...
> }
> </script>

The first parameter to getUserMedia should be defined as a WebIDL dictionary [2]. I'd recommend changing the definition as follows:

From--
[NoInterfaceObject]
interface MediaStreamOptions {
    attribute boolean audio;
    attribute boolean video;
};

To--
dictionary MediaStreamOptions {
    boolean audio;
    boolean video;
}


I believe this change merely aligns the syntax with the expected usage behavior as shown in the example.

-Travis

[1] http://dev.w3.org/2011/webrtc/editor/getusermedia.html#mediastreamoptions
[2] http://dev.w3.org/2006/webapi/WebIDL/#idl-dictionaries

Received on Wednesday, 30 November 2011 18:55:02 UTC