W3C home > Mailing lists > Public > public-media-annotation@w3.org > May 2011

Re: AW: Decision needed before exit LC

From: Pierre-Antoine Champin <pierre-antoine.champin@liris.cnrs.fr>
Date: Thu, 19 May 2011 19:47:32 +0200
Message-ID: <4DD557B4.3040305@liris.cnrs.fr>
To: "Höffernig, Martin" <Martin.Hoeffernig@joanneum.at>
CC: "public-media-annotation@w3.org" <public-media-annotation@w3.org>
On 05/19/2011 12:45 PM, Höffernig, Martin wrote:
> Dear all,
> 
>> Note also that I therefore renamed ma:isRelatedTo to
>> ma:hasRelatedResource, in order to be consistent in our naming
>> scheme.
> 
> In the latest MA ontology version (rev 34), ma:isRelatedTo is now
> defined as the inverse of ma:hasRelatedResource.

Indeed. This is now consistent with the naming scheme of other
properties. It used to be an exception, justified by the fact that this
was the only symetric property in our ontology. As this is no longer the
case, I aligned it with the others.

> ma:isRelatedTo is
> only defined as ObjectProperty without domain/range assertions even
> though the definition of ma:hasRelatedResource includes a domain
> assertion, namely ma:MediaResource. From my point of view, missing
> corresponding domain/range assertions between these two properties
> could lead to confusion about the correct usage. Therefore I suggest
> to add range ma:MediaResource to ma:isRelatedTo.

Again, this was a choice to keep the RDF/XML file small enough and more
readable. Furthermore, editors are usually smart enough to automatically
infer domain and range of inverse properties (at least, Protégé does).

> Furthermore I would
> rename ma:isRelatedTo to ma:hasRelatedMediaResource, which would
> describe the semantics better.

It would, but again it would also be inconsistent with the naming scheme
adopted for other properties...

  pa

> 
> Best, Martin
Received on Thursday, 19 May 2011 17:47:57 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 May 2011 17:47:59 GMT