W3C home > Mailing lists > Public > public-media-annotation@w3.org > February 2011

RE : Agreed Changes in the 5.1.2 Descriptive properties (Core Set) table for the Type definition column.

From: Evain, Jean-Pierre <evain@ebu.ch>
Date: Wed, 16 Feb 2011 19:30:58 +0100
To: Pierre-Antoine Champin <pierre-antoine.champin@liris.cnrs.fr>, Thierry Michel <tmichel@w3.org>
CC: "public-media-annotation@w3.org" <public-media-annotation@w3.org>
Message-ID: <7D1656F54141C042A1B2556AE5237D60010EAF8F13DC@GVAMAIL.gva.ebu.ch>
Thanks Pierre Antoine. Revision 30 of the RDF for final review.

Regards,

Jean-Pierre


________________________________________
De : Pierre-Antoine Champin [pierre-antoine.champin@liris.cnrs.fr]
Date d'envoi : mercredi, 16. février 2011 10:11
À : Thierry Michel
Cc : Evain, Jean-Pierre; public-media-annotation@w3.org
Objet : Re: Agreed Changes in the  5.1.2 Descriptive properties (Core Set)             table for the Type definition column.

Thanks Thierry, and all you guys for the good work;

sorry I couldn't join you, even on the phone or IRC. I had great
interest in the discussion, but unfortunately the schedule was not
compatible with my timezone :-/

I just reviewed in section 7.2 the correspondence table btw the abstract
ontology and RDF ontology, to check if they were still consistent, some
modifications are required:


* change 'contributor.identifier' to 'contributor.contributor' (left column)

* change 'creator.identifier' 'creator.contributor' (left column)

* add a line   | creator.role | (2) |   just after 'creator.creator'

* change 'ma:locationCoordinateSystem' to
'ma:hasLocationCoordinateSystem (3)' (right column)

* remove line 'rating.identifier'

* change line  | rating.type | ma:hasRatingScheme |  by
| rating.ratingSystem | ma:hasRatingScheme |

* change 'relation.identifier' to 'relation.target' (left column)

* change 'relation.relation' to 'relation.type' (left column)

* change 'copyright.identifier' to 'copyright.holder' (left column)

* change 'policy.policy' to 'policy.statement' (left column)

* change 'targetAudience.identifier' to 'targetAudience.audience' (left
column)

* change 'targetAudience.classification' to
'targetAudience.classificationSystem' (left column)

* change 'ma:format' to 'ma:hasFormat (3)' (right column)

* in note (2), "ontology" should be replaced by "RDF ontology"


also, this has some impact on the RDF ontology; I think Jean-Pierre will
have noticed it, but just to be sure:


* ma:localtionCoordinateSystem should be renamed to
ma:hasLocationCoordinateSystems and become an owl:ObjectProperty, as its
values can now be URIs

* ma:format should be renamed to ma:hasFormat and become an
owl:ObjectProperty, as its values can now be URIs

* MAYBE should we rename ma:hasRatingScheme to ma:hasRatingSystem in
order to be more consistent with the ontology; this would require
updating the correspondence table as well...

* MAYBE idem for ma:hasClassificationScheme, renamed to
ma:hasClassificationSystem ?


thanks again for this thorough work.

   pa


On 02/15/2011 11:21 PM, Thierry Michel wrote:
>
>
> I have incorporated the changes in the Ontology document.
> http://dev.w3.org/2008/video/mediaann/mediaont-1.0/mediaont-1.0.html
>
> It may be easier to review here ;-)
>
> It includes this morning resolution + your latest statement for
> targetAudience + Werner suggestion for policy to keep only the String
> value.
>
>
>
>
>
>
>
>
>
>
>
>> More detailed review:
>>
>> Keyword should be marked as [no change]
>>
>> targetAudience:
>>
>> A tuple identifying the classification @@@ system @@@ (e.g., a parental
>> guidance issuing agency, or a targeted geographical region) and the value
>> given in this classification.
>>
>> Change to:
>>
>> A tuple identifying the audience being addressed (demographic class,
>> parental guidance group, or geographical region)  and the classification
>> @@@ system @@@ (e.g., a parental guidance issuing agency).
>>
>>
>> BTW, thanks for taking all these notes.
>>
>> Jean-Pierre
>>
>> -----Original Message-----
>> From: Thierry Michel [mailto:tmichel@w3.org]
>> Sent: mardi, 15. février 2011 22:03
>> To: Evain, Jean-Pierre
>> Cc: public-media-annotation@w3.org
>> Subject: Agreed Changes in the 5.1.2 Descriptive properties (Core Set)
>> table for the Type definition column.
>>
>> Here are the changes in the Ontology for the 5.1.2 Descriptive properties
>> (Core Set) table for the Type definition column.
>>
>> Identification
>> identifier   (attName="identifier", attValue="URI")                                  [NO change]
>> title          { (attName="title", attValue="String"), (attName="type",
>> attValue="URI" | "String"")? }               [CHANGED]
>> language    (attName="language", attValue="URI" | "String") [NO change]
>> locator        (attName="locator", attValue="URI")                                           [NO change]
>>
>> Creation
>> contributor  { (attName="contributor", attValue="URI" | "String"),
>> (attName="role", attValue="URI" | "String")? }       [CHANGED]
>> creator          { (attName="creator", attValue="URI" | "String"),
>> (attName="role", attValue="URI" | "String")? }      [CHANGED]
>> date                 { (attName="date", attValue="Date"), (attName="type",
>> attValue="URI" | "String")? }                        [CHANGED]
>> location         { (attName="name", attValue="URI" | "String")?,
>> (attName="longitude", attValue="Double")?, (attName="latitude",
>> attValue="Double")?, (attName="altitude", attValue="Double")?,
>> (attName="coordinateSystem", attValue="URI" | "String")? }   [CHANGED]
>>
>> Content description
>> description  (attName="description", attValue="String")      [NO change]
>> keyword          (attName="keyword", attValue="URI" | "String")
>> genre              (attName="genre", attValue="URI" | "String")      [NO change]
>> rating           { (attName="value", attValue="Double"),
>> (attName="ratingSystem", attValue="URI" | "String")?, {(attName="min",
>> attValue="Double"), (attName="max", attValue="Double")}? }   [CHANGED]
>>
>> Relational
>> relation     { (attName="target", attValue="URI" | "String"),
>> (attName="type", attValue="URI" | "String")? }       [CHANGED]
>> collection   (attName="collection", attValue="URI" | "String") [NO change]
>>
>> Rights
>> copyright    { (attName="copyright", attValue="URI" | "String"),
>> (attName="holder", attValue="URI" | "String")? } [CHANGED]
>> policy           { (attName="statement", attValue="URI" | "String"),
>> (attName="type", attValue="URI" | "String")? }   [CHANGED]
>>
>> change the text to ....
>> A tuple containing a policy statement either human readable as a string or
>> machine resolvable as a URI, and the type of the policy to provide more
>> information as to the nature
>> of the policy. See examples.
>>
>> Distribution
>> publisher          (attName="publisher", attValue="URI" | "String")  [NO
>> change]
>> targetAudience       { (attName="audience", attValue="URI" | "String"),
>> (attName="classificationSystem", attValue="URI" | "String") } [CHANGED]
>> A tuple identifying the classification @@@ system @@@ (e.g., a parental
>> guidance issuing agency, or a targeted geographical region) and the value
>> given in this classification.
>>
>> Fragment
>> fragment           { (attName="identifier", attValue="URI"), (attName="role",
>> attValue="URI" | "String")? }        [CHANGED]
>> namedFragment        { (attName="identifier", attValue="URI"), (attName="label",
>> attValue="String") }                 [NO change]
>>
>>
>> Technical Properties
>> frameSize    { (attName="width", attValue="Double"), (attName="height",
>> attValue="Double"), (attValue="unit", attValue="String")? }  [NO change]
>> compression  (attName="compression", attValue="URI" | "String")      [NO
>> change]
>> change the text to ....
>> The compression type used. For container files (e.g., QuickTime, AVI), the
>> compression is not defined by the format, as a container file can have
>> several tracks that each use different encodings. In such a case, several
>> compression instances should be used. Thus, querying the compression
>> property of the track media fragments will return different values for
>> each track fragment.
>> Either or both of two values may be supplied: a free-form string which can
>> be used for user display or when the naming convention is lost or unknown.
>> The URI consists of a absolute-URI (RFC 3986, section 4.3) and fragment
>> (RFC 3986, section 3.5), that is, e.g. in the form absolute-URI#name. The
>> absolute-URI identifies the naming convention used for the second
>> parameter, which is a string name from that convention.  A URL is
>> preferred for the URI, and if it is used, it (a) might contain a date in
>> the form mmyyyy, indicating that the owner of the domain in the URL agreed
>> to its use as a label around that date and (b) should be de-referencable,
>> yielding an informative resource about the naming convention.
>> Note that this use of URIs with fragments also closely matches RDF (see
>> <http://www.w3.org/TR/rdf-concepts/#section-fragID>).
>> Note that for some container files, the format parameter can also carry an
>> extended MIME type to document this; see [RFC 4281] for one such instance.
>>
>>
>>
>> duration                             (attName="duration", attValue="Double")                                                 [NO change]
>> format                                       (attName="format", attValue="URI" | "String")                   [CHANGED]
>> samplingRate                 (attName="samplingRate", attValue="Double")                       [NO
>> change]
>> frameRate                    (attName="frameRate", attValue="Double")                                                [NO change]
>> averageBitRate       (attName="averageBitRate", attValue="Double")       [NO
>> change]
>> numTracks      { (attName="number", attValue="Integer"), (attName="type",
>> attValue="String")? } [NO change]
>>
>>
>>
>>
>> Change the Statement before the table as follows ... in 5.1.1 Description
>> of the approach followed for the property definitions
>>
>>
>>
>> The following syntax is used for the type descriptions:
>>
>>      *   ( ) (parentheses) are used to indicate a attribute/value pair
>>      *   | (vertical bar) is used to indicate a choice between different
>> values
>>      *   { } (curly brackets) are used to define a complex type, i.e., a
>> tuple of attribute/value pairs
>>      *    ? (question mark) is used to indicate an optional element
>>
>> contributor  { (attName="contributor", attValue="URI" | "String"),
>> (attName="role", attValue="URI" | "String")? }
>> is interpreted as a complex type that has two elements.
>> The first identifies the contributor of a media resource by using a URI or
>> a string.
>> The second specifies an optional role, which is defined by a string.
>> Elements are comma separated, and the collection of elements that makes up
>> the complex type is enclosed in curly brackets.
>>
>>
>> Change the compression example to ....
>> @@@ TBD
>>
>>
>> --
>> Thierry Michel
>> W3C
>>
>>
>
>

Received on Wednesday, 16 February 2011 18:32:47 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 16 February 2011 18:33:04 GMT