W3C home > Mailing lists > Public > public-media-annotation@w3.org > August 2010

RE: RE : [mawg] action-249: Ontology rev 5 available & call for competency questions wrt. to actor - role part of the ontology

From: Evain, Jean-Pierre <evain@ebu.ch>
Date: Thu, 26 Aug 2010 11:00:41 +0200
To: 'Pierre-Antoine Champin' <pierre-antoine.champin@liris.cnrs.fr>
CC: Tobias Bürger <tobias.buerger@salzburgresearch.at>, "public-media-annotation@w3.org" <public-media-annotation@w3.org>
Message-ID: <7D1656F54141C042A1B2556AE5237D60010CEEB7F145@GVAMAIL.gva.ebu.ch>
Thanks for clarification.

I have to look at this and in particular the use of cardinality on properties. That looks interesting.

JP


-----Original Message-----
From: Pierre-Antoine Champin [mailto:pierre-antoine.champin@liris.cnrs.fr] 
Sent: jeudi, 26. août 2010 10:50
To: Evain, Jean-Pierre
Cc: Tobias Bürger; public-media-annotation@w3.org
Subject: Re: RE : [mawg] action-249: Ontology rev 5 available & call for competency questions wrt. to actor - role part of the ontology

On 26/08/2010 07:01, Evain, Jean-Pierre wrote:
> 2/ In this case I personally strongly prefer saying that duration
> doesn't apply to picture (perfectly valid statement supported by the
> RDF syntax) instead of saying that picture is a subclass of a
> mediaresource with duration=0 (or audio subclass of framewidth=0 to
> which you should add and/or frameheight=0???)???  It is (IMHO) less
> elegant, less rigourous, and I am not even sure it is less complex
> ;-)
> 
> I truely can't see what is wrong with the proposed approach. This is
> semantically absolutely correct and exploits RDF statements in a
> valid way.

First, I was too lazy, and might have given the wrong impression when
using Protégé's short notation: I do not suggest to state that images
have a duration of 0, but that they have zero duration associated with
them. From now on, I will stick to N3-encoded OWL...

Second, I do not claim that anything in semantically "wrong" in the
proposed approach or even too "complex" (I let this to inference engine
implementers ;). It is merely a matter of readability.

Those points being clarified (I hope), let me rephrase:

When you write

  ma:duration rdfs:domain [
    owl:intersectionOf (
      ma:MediaResource
      [ owl:complementOf ma:Image ]
    )
  ].

I read "every MediaResource, except Images, can have a duration".
This *may* give the wrong impression that Images are the only
MediaResource which have no duration, even though this is not stricly
entailed by the axiom above.

If you wrote

  ma:frameWidth rdfs:domain ma:MediaResource .
  ma:Image rdfs:subClassOf ma:MediaResource, [
    a owl:Restriction ;
    owl:onProperty ma:duration ;
    owl:cardinality 0
  ]

I read "every MediaResource can have a duration. Images are
MediaResources that have no duration".

This makes the exception about Image a separate statement from the
general domain expression. Furthermore, if anyone was to add a new
duration-less subclass of MediaResource, they could use the same pattern:

  :Smell rdfs:subClassOf ma:MediaResource,  [
    a owl:Restriction ;
    owl:onProperty ma:duration ;
    owl:cardinality 0
  ].

Of course, the pattern has to be repeated if several properties are to
be excluded:

  ma:AudioTrack rdfs:subClassOf ma:MediaResource, [
    a owl:Restriction ;
    owl:onProperty ma:frameHeight ;
    owl:cardinality 0
  ], [
    a owl:Restriction ;
    owl:onProperty ma:frameWidth ;
    owl:cardinality 0
  ].

  pa
Received on Thursday, 26 August 2010 09:05:36 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 August 2010 09:05:36 GMT