W3C home > Mailing lists > Public > public-ldp@w3.org > September 2013

Re: ISSUE-81 Suggested Name Changes

From: David Wood <david@3roundstones.com>
Date: Sat, 14 Sep 2013 21:10:19 -0400
Message-Id: <FB9E5A11-8B53-46B1-A233-AEECBAF6AAFE@3roundstones.com>
To: "public-ldp@w3.org" <public-ldp@w3.org>
Ugh!  Sorry.  Please ignore this since it went to the wrong list.

Regards,
Dave
--
http://about.me/david_wood



On Sep 14, 2013, at 21:00, David Wood <david@3roundstones.com> wrote:

> Hi all,
> 
> This message attempts to collate suggested name changes for the membership predicates in ISSUE-81.
> 
> ISSUE-81
> http://www.w3.org/2012/ldp/track/issues/81
> 
> We seem to have developed consensus at FTF4 on leaving the design for ISSUE-81 as it is, but changing the names of the terms to be more clear.  The current terms are:
> 
> ldp:membershipContainer
> ldp:membershipContainsRelation
> ldp:membershipContainedByRelation
> ldp:membershipMemberCreationIdentifier
> 
> Suggested changes follow, annotated with the names of the people who suggested them.
> 
> Ted:
> ldp:membershipSubject --> ldp:containmentContainer
> ldp:membershipPredicate --> ldp:containmentRelation
> ldp:membershipObject --> ldp:containmentAddedMember
> ldp:membershipPredicateInverse --> ldp:containmentMemberRelation
> 
> John:
> (?c, ?p, member)
> ldp:container ?c
> ldp:containsRelation ?p
> # object (member) varies
> 
> (member, ?p, ?c)
> # subject (member) varies
> ldp:containedByRelation ?p
> ldp:container ?c
> 
> (?c, ?p, member from foaf:primaryTopic)
> ldp:container ?c
> ldp:containsRelation ?p
> ldp:insertedContentRelation foaf:primaryTopic
> 
> Miguel:
> I would merge ldp:membershipSubject and ldp:membershipObject, as they always refer to the same resource, the one that aggregates the members:
> 
> ldp:membershipSubject & ldp:membershipObject --> ldp:memberAggregator
> ldp:membershipPredicate --> ldp:memberAggregationRelation
> ldp:membershipPredicateInverse --> ldp:memberInverseAggregationRelation
> 
> Roger:
> membershipSubject -> domainSelector (or maybe fromSelector, startSelector, originSelector ... )  
> membershipObject -> rangeSelector (or maybe toSelector, endSelector, destinationSelector ...) 
> membershipPredicate -> no change (?) 
> membershipPredicateInverse -> no change (?) 
> 
> Regards,
> Dave
> --
> http://about.me/david_wood
> 
> 
> 



Received on Sunday, 15 September 2013 01:10:43 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:03:11 UTC