W3C home > Mailing lists > Public > public-i18n-its@w3.org > January to March 2006

[Bug 3017] rename documentRules and documentRule

From: <bugzilla@wiggum.w3.org>
Date: Thu, 23 Mar 2006 01:22:45 +0000
CC:
To: public-i18n-its@w3.org
Message-Id: <E1FMEXF-0001I2-Q2@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=3017





------- Comment #5 from fsasaki@w3.org  2006-03-23 01:22 -------
(In reply to comment #4)
> This issue (Bug #3017) is one of the topics for discussion this week (and
> decision at the Wed Mar-29 teleconference).
> 
> Summary:
> 
> 1) The question: how should the current 'documentRules' should be named?
> 
> Since we don't have schemaRules the name documentRules may not be appropriate
> anymore. [Note that the renaming of documentRule is resolved since we decided
> to go for translateRule, termRule, etc.]
> 
> Several names are proposed: globalRules, itsRules, rules.
> 
> 
> 2) The question: what should be the suffix for the 'value passing/pointing'
> attribute?
> 
> The name of the attributes that use to be called xyzMap in the Mandelieu
> proposal need to reflect their 'value passing/pointing' aspect rather than a
> 'mapping' that is something different. This applies for: locInfoMap,
> locInfoRefMap, rubyBaseMap, rubyTextMap, termRefMap, etc.
> 
> Several suffixes are proposed: xyzPointer, xyzPassThrough, xyzValue (and I may
> forget some).
> 
> 
> My personnal (current) option:
> 
> 1) rules
> 2) xyzPointer
> 
> -yves
> 

+1 for xyzPointer
-1 for "rules". This has to do with the schema redesign proposed at
http://lists.w3.org/Archives/Public/public-i18n-its/2006JanMar/0301.html . For
each data category, so far we had the discinction "global" versus "local",
which is also in the schema. So I would propose "globalRules".
Received on Thursday, 23 March 2006 01:22:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:12:46 GMT