W3C home > Mailing lists > Public > public-i18n-its@w3.org > January to March 2006

RE: Issue of locInfoType - To keep or not

From: Yves Savourel <ysavourel@translate.com>
Date: Wed, 22 Mar 2006 15:36:02 -0700
To: "'Richard Ishida'" <ishida@w3.org>, <public-i18n-its@w3.org>
Message-ID: <000601c64e01$003a1c60$8f05a8c0@Breizh>

Hi all,

A thought occurred to while reading an IRC line from Christian in the meeting minutes. Instead of the locInfoType or a new
<locAlert> data category maybe we can just replace the locInfoType by a choice in the attribute/element locInfo.

So instead of:

<its:locInfoRule its:locInfoType="alert|description">

We would have:

 <locInfoAlert>...</locInfoAlert> or <locInfoDescription>...</locInfoDescription>

And locally, instead of:

its:locInfoAlert + an optional its:locInfoType="alert|description"

We would have 

its:locInfoAlert or its:locInfoDescription 

This way there is no more optional attribute and we have only one its:locInfoSomething locally.

If we were to do that I would also maybe rename its:locInfoDescription by its:locInfoNote (it just feels more appropriate to me, but
that's just an opinion).

Just an idea. I'm not sure if it's more elegant or useful.
For the next draft we decided to keep things the way they are.



From: Richard Ishida [mailto:ishida@w3.org] 
Sent: Tuesday, March 21, 2006 4:09 AM
To: 'Yves Savourel'; public-i18n-its@w3.org
Subject: RE: Issue of locInfoType - To keep or not

I would also prefer to remove the locInfoType attribute, but there is a third solution that i prefer.
In addition to the locInfo data category have a locAlert data category.  I think relying on people to add text to a note to
distinguish these two types of localization note will lead to problems - not least if the notes are written in another language
(such as Russian). 
I also think we need to be careful about changing the requirements to fit implementation snags.  

Richard Ishida
Internationalization Lead
W3C (World Wide Web Consortium)




	From: public-i18n-its-request@w3.org [mailto:public-i18n-its-request@w3.org] On Behalf Of Yves Savourel
	Sent: 16 March 2006 06:13
	To: public-i18n-its@w3.org
	Subject: Issue of locInfoType - To keep or not

	Hi all, 

	There is an item listed in the Mandelieu proposals that I'd like to dispose of at the next teleconference. It's not a
crucial one but it affect the markup itself, so we need to address it.

	We have currently an optional attribute locInfoType with the values "alert|description" (and no default set for now). 

	The question is shall we keep it or not? 

	Advantages to keep it: 

	- Allows to make a distinction between different types of loc info. 


	- make things a bit more verbose, and add more things to do at the implementation. 
	- we would need to decide where it fits in the conformance (any specific processing expectation) 
	- if we keep it we need to have a default value for it (alert or description?) 

	My comments: 

	Overall I don't see much benefits into having it. From an implementation viewpoint (at least from my prospective) this will
translate into a note that will have a 'ALERT' word in front of the note, or nothing. That's it.

	If we keep it I think the default value should be 'description'. 

	I would be for removing @locInfoType simply because it doesn't seem to bring much and that would make ITS a tad lighter. But
it's not at all a strong opinion and I'll go with the pack on this one.

Received on Wednesday, 22 March 2006 22:36:15 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:43:06 UTC