Names of Operations and Lack of Operations

Hello,

the comments of my last mail have not been answered yet,
this is why I want to again express my thoughts on the naming and lack 
of operations.

1.) CRUD is usually an acronym for Create, Read, Update, Delete whereas
the spec uses "Replace" for "R".

2.) There are corresponding operations CreateResourceOperation, 
ReplaceResourceOperation and DeleteResourceOperation.
This incomplete because a ReadOperation is missing and I have pointed 
out in my earlier post why I think this is essential.
Furthermore there should be an UpdateOperation because a modification 
operation of a resource could be
a complete replace (existing properties might be removed if missing in 
the update) or an update (only new and changed properties
are modified).
Maybe there could lalso be a ModificationOperation with two subclasses.
This also matches a current trend in REST API design where you en up 
with the following mapping on HTTP operations:

GET -> read
POST -> create
PUT -> replace
PATCH -> update
DELETE -> delete

Greets, Thomas

Received on Monday, 30 September 2013 06:32:33 UTC