W3C home > Mailing lists > Public > public-html@w3.org > March 2011

[Bug 12213] New: What!? Is this a joke, if I get the value of an input element in 'filename' mode, I get the filename with an extra string prepended to it, so that to use the filename I will always have to strip the first 12 characters? That is really messed up.

From: <bugzilla@jessica.w3.org>
Date: Tue, 01 Mar 2011 17:48:49 +0000
To: public-html@w3.org
Message-ID: <bug-12213-2495@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=12213

           Summary: What!? Is this a joke, if I get the value of an input
                    element in 'filename' mode, I get the filename with an
                    extra string prepended to it, so that to use the
                    filename I will always have to strip the first 12
                    characters? That is really messed up.
           Product: HTML WG
           Version: unspecified
          Platform: Other
               URL: http://www.whatwg.org/specs/web-apps/current-work/#com
                    mon-input-element-apis
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: HTML5 spec (editor: Ian Hickson)
        AssignedTo: ian@hixie.ch
        ReportedBy: contributor@whatwg.org
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-wg-issue-tracking@w3.org,
                    public-html@w3.org


Specification:
http://www.whatwg.org/specs/web-apps/current-work/multipage/common-input-element-attributes.html
Section:
http://www.whatwg.org/specs/web-apps/current-work/#common-input-element-apis

Comment:
What!? Is this a joke, if I get the value of an input element in 'filename'
mode, I get the filename with an extra string prepended to it, so that to use
the filename I will always have to strip the first 12 characters? That is
really messed up.

Posted from: 136.205.16.22
User agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12)
Gecko/20101026 Firefox/3.6.12

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Tuesday, 1 March 2011 17:48:51 UTC

This archive was generated by hypermail 2.3.1 : Monday, 29 September 2014 09:39:23 UTC