W3C home > Mailing lists > Public > public-html@w3.org > April 2011

[Bug 12546] New: MEDIA CONTROLLER requires autoplay attribute for grouped multitrack

From: <bugzilla@jessica.w3.org>
Date: Sat, 23 Apr 2011 03:16:35 +0000
To: public-html@w3.org
Message-ID: <bug-12546-2495@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=12546

           Summary: MEDIA CONTROLLER requires autoplay attribute for
                    grouped multitrack
           Product: HTML WG
           Version: unspecified
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML Microdata (editor: Ian Hickson)
        AssignedTo: ian@hixie.ch
        ReportedBy: jfoliot@stanford.edu
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-wg-issue-tracking@w3.org,
                    public-html@w3.org


The MediaController object currently always autoplay without a means to control
this autoplay behaviour and without consistent autoplay across all the slave
elements. This is inconsistent with in-band multitrack media resources. One of
the main use cases for the introduction of autoplay attributes was that this
allows the UA to expose a user setting that disables autoplay behaviour, which
is particularly useful to vision-impaired users who cannot easily locate
autoplaying media elements.

Therefore, we request addition of a autoplay IDL attribute on the
MediaController object.
When it is set to true, playback of the grouped multitrack must start once all
slave elements have reached a readyState of HAVE_ENOUGH_DATA and can play
through.

It is set to true when at least one of the media elements in the group have a
autoplay IDL attribute that is set to true, false otherwise.
Alternatively, it would also be acceptable to set it to true only when all of
the media elements in the group have a autoplay IDL attribute that is set to
true, though that seems overly verbose.

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Saturday, 23 April 2011 03:16:37 UTC

This archive was generated by hypermail 2.3.1 : Monday, 29 September 2014 09:39:24 UTC