W3C home > Mailing lists > Public > public-html@w3.org > March 2010

RE: ISSUE-4 (html-versioning) (vs. ISSUE-30 longdesc)

From: Leonard Rosenthol <lrosenth@adobe.com>
Date: Sun, 28 Feb 2010 22:49:25 -0800
To: Maciej Stachowiak <mjs@apple.com>, Larry Masinter <LMM@acm.org>
CC: "'Toby Inkster'" <tai@g5n.co.uk>, "'Adam Barth'" <w3c@adambarth.com>, "'HTML WG'" <public-html@w3.org>
Message-ID: <D23D6B9E57D654429A9AB6918CACEAA97CA6084B02@NAMBX02.corp.adobe.com>
So does this mean that there will be an XML Schema for the XHTML-serialization of HTML5, so that it can be validated? 

Leonard

-----Original Message-----
From: public-html-request@w3.org [mailto:public-html-request@w3.org] On Behalf Of Maciej Stachowiak
Sent: Monday, March 01, 2010 3:28 AM
To: Larry Masinter
Cc: 'Toby Inkster'; 'Adam Barth'; 'HTML WG'
Subject: Re: ISSUE-4 (html-versioning) (vs. ISSUE-30 longdesc)


On Feb 28, 2010, at 5:43 PM, Larry Masinter wrote:

> There was another use case that pushed me toward continuing
> with DOCTYPE, which is the extensive use of DOCTYPE in XML/XHTML
> editors.

I vaguely recall that last time this came up, further discussion found  
that none of these tools seemed to actually depend on a version- 
bearing DOCTYPE declaration. But I did a quick check myself:

> http://manual.altova.com/XMLSpy/spyprofessional/index.html?xshtmlcssjson_html.htm

Accepts either a DTD or an XML Schema, for XML serialization only. An  
XML Schema would be able to more accurately represent HTML5  
conformance requirements. So: (a) No Doctype needed. (b) If one was  
present, it would at most be used to automatically load the referenced  
DTD, but HTML5 doesn't have a DTD.

> http://www.oxygenxml.com/xhtml_editor.html

Supports either DTDs or schemas. Only appears to know about Schemas or  
DTDs from a hardcoded list. So: (a) No Doctype needed. (b) Needs to be  
updated for XHTML5 no matter what DTD syntax is used.

> http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.wst.webtools.doc.user/topics/tjprefs.html

Sounds like one would need to use the legacy-compat doctype for the  
auto-doctype-insertion feature, for HTML documents. It does not seem  
to care about the contents of the DOCTYPE declaration, just offers to  
insert it automatically. Thus unclear how it would benefit from a  
version number.

> http://www.xmlmind.com/xmleditor/_distrib/doc/xhtml/xhtml_dtds.html

Looks like this is hardcoded to recognize only the XHTML 1.0 DTDs as  
XHTML documents. An HTML5 DTD bearing a version number would be just  
as unrecognized as "<!DOCTYPE html>" or no DTD at all.

> and a few more. Since there is substantial deployed
> infrastructure that knows about DOCTYPE-based
> editing and conformance validation, why add something
> that doesn't match reality?

DTD-based validation can't come even close to validating HTML5.

> The problem with the root element version parameter is
> that it can't as easily be used by a generic editor.

All of the editors in this set that are truly generic and which care  
about the DTD contents seem to support manual association of a DTD,  
and support XML Schema as an alternative.

Regards,
Maciej
Received on Monday, 1 March 2010 06:50:54 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 00:17:04 GMT