W3C home > Mailing lists > Public > public-html@w3.org > September 2009

[Bug 7765] Maybe progress should be named fetchcachefile or some such

From: <bugzilla@wiggum.w3.org>
Date: Wed, 30 Sep 2009 15:17:42 +0000
To: public-html@w3.org
Message-Id: <E1Mt0w2-0005xN-Cj@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=7765


Anne <annevk@opera.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |annevk@opera.com
             Status|RESOLVED                    |REOPENED
           Keywords|                            |NE
         Resolution|NEEDSINFO                   |
            Summary|Maybe progress should be    |Maybe progress should be
                   |named fetchcachefile or some|named fetchcachefile or some
                   |such instead as that seems  |such
                   |much more closely to what is|
                   |used for. However, I don't  |
                   |quite understand why you    |
                   |would not want more detailed|
                   |progress events here so you |
                   |can show a progress bar to  |
                   |the user                    |




--- Comment #2 from Anne <annevk@opera.com>  2009-09-30 15:17:41 ---
Updating a progress bar every 250ms will give you bad UI. You might as well not
have it then I think. From experience with progress events for XMLHttpRequest
you want something about every 50ms to get a smooth download bar.

The reason I suggested another name is that progress is very generic and we
might want to use it for something else in the future. The function here is
also very specific so it seems better to keep the name consistent with that.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Wednesday, 30 September 2009 15:17:45 UTC

This archive was generated by hypermail 2.3.1 : Monday, 29 September 2014 09:39:08 UTC