W3C home > Mailing lists > Public > public-html@w3.org > May 2009

Re: [WF2] new attributes that often conflict with actual pages

From: Simon Pieters <simonp@opera.com>
Date: Wed, 27 May 2009 13:41:46 +0200
To: "Sean Hogan" <shogun70@westnet.com.au>, public-html@w3.org, "Ian Hickson" <ian@hixie.ch>, "Hallvord R. M. Steen" <hallvord@opera.com>
Cc: "Laurens Holst" <lholst@students.cs.uu.nl>
Message-ID: <op.uuk6rwrqidj3kv@zcorpandell.linkoping.osa>
On Sat, 23 May 2009 16:45:36 +0200, Sean Hogan <shogun70@westnet.com.au> wrote:

> Regarding the renamed submit-button attributes: formaction, formmethod,  
> formtarget, formenctype, etc.
> These names could be confusing, especially in JS code where  
> button.formaction resembles button.form.action.

They are actually camelCased i.e. button.formAction.

> Perhaps they could be named "altaction", etc.
> Or even "submitaction", etc.

I don't think these are any better.

Simon Pieters
Opera Software
Received on Wednesday, 27 May 2009 11:42:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 00:16:37 GMT