W3C home > Mailing lists > Public > public-html@w3.org > June 2009

Re: [WF2] new attributes that often conflict with actual pages

From: Sean Hogan <shogun70@westnet.com.au>
Date: Sat, 13 Jun 2009 12:38:47 +1000
Message-ID: <4A331137.3050102@westnet.com.au>
To: Ian Hickson <ian@hixie.ch>
CC: Simon Pieters <simonp@opera.com>, Anne van Kesteren <annevk@opera.com>, public-html@w3.org, "Hallvord R. M. Steen" <hallvord@opera.com>, Laurens Holst <lholst@students.cs.uu.nl>
Ian Hickson wrote:
> On Sun, 24 May 2009, Sean Hogan wrote:
>   
>> Regarding the renamed submit-button attributes: formaction, formmethod, 
>> formtarget, formenctype, etc.
>>
>> These names could be confusing, especially in JS code where 
>> button.formaction resembles button.form.action.
>>
>> Perhaps they could be named "altaction", etc. Or even "submitaction", 
>> etc.
>>     
>
> It's a judgement call, but I have to say that personally I don't really 
> like submitAction more than formAction.
>
>   
On second thoughts...
Once the new form-submission functionality is implemented in browsers 
the need for DOM scripting will be negligible so this naming clash 
probably doesn't matter.
Received on Saturday, 13 June 2009 02:40:07 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 00:16:38 GMT