W3C home > Mailing lists > Public > public-html@w3.org > August 2008

[Bug 5964] New: getting width/height on <embed>, <iframe>, <object> and <video>

From: <bugzilla@wiggum.w3.org>
Date: Wed, 13 Aug 2008 15:33:55 +0000
To: public-html@w3.org
Message-ID: <bug-5964-2495@http.www.w3.org/Bugs/Public/>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=5964

           Summary: getting width/height on <embed>, <iframe>, <object> and
                    <video>
           Product: HTML WG
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Spec bugs
        AssignedTo: dave.null@w3.org
        ReportedBy: simonp@opera.com
         QAContact: public-html-bugzilla@w3.org
                CC: ian@hixie.ch, mike@w3.org, public-html@w3.org


In Firefox, Opera, Safari and IE, getting the width and height DOM attributes
on <embed>, <iframe> and <object> when the content attributes are absent return
the empty string. The spec says it should be 0.

http://software.hixie.ch/utilities/js/live-dom-viewer/?%3C!DOCTYPE%20html%3E%0D%0A%3Cstyle%3Eembed%2C%20object%2C%20iframe%20%7B%20width%3A123px%3B%20height%3A45px%3B%20%7D%3C%2Fstyle%3E%0D%0A%3Cscript%3E%0D%0Aonload%3Dfunction()%7B%0D%0Avar%20e%20%3D%20document.body.firstChild%3B%0D%0Ado%20%7B%0D%0Aw(e.nodeName%20%2B%20'%3A%20'%20%2B%20e.width%20%2B%20'%2C%20'%20%2B%20e.height)%0D%0A%7D%20while%20(e%20%3D%20e.nextSibling)%3B%0D%0A%7D%0D%0A%3C%2Fscript%3E%0D%0A%3Cembed%3E%3Cobject%3E%3C%2Fobject%3E%3Ciframe%3E%3C%2Fiframe%3E%3Cimg%3E%3Cvideo%3E%3C%2Fvideo%3E

Perhaps the spec should require this and make <video> consistent with the other
3?


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Wednesday, 13 August 2008 15:34:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 00:16:21 GMT