[Bug 20758] New: remove() should be an asynchronous operation

https://www.w3.org/Bugs/Public/show_bug.cgi?id=20758

            Bug ID: 20758
           Summary: remove() should be an asynchronous operation
    Classification: Unclassified
           Product: HTML WG
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Media Source Extensions
          Assignee: adrianba@microsoft.com
          Reporter: adrianba@microsoft.com
        QA Contact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-media@w3.org

There may be a large amount of work to do to process a remove() operation and
we should not block the UI thread while this happens.

Proposed Change: expand the "append" related events and attribute for the
remove operation

- Section 4: rename "appending" attribute to "updating" through the whole
section
- Section 4: rename "appendstart" to "updatestart" through the section
- Section 4: rename "appendend" to "updateend" through the section 
- Section 4.1: in the updating definition, add "remove()" operation to the list
- Section 4.2: in the definition of the remove() operation insert the following
between steps 4 and 5
   o Set the updating attribute to true.
   o Queue a task to fire a simple event named updatestart at this SourceBuffer
object.
- Then after step 5.4, add the following
  o Set the updating attribute to false.
  o Queue a task to fire a simple event named updateend at this SourceBuffer
object.

-- 
You are receiving this mail because:
You are on the CC list for the bug.

Received on Thursday, 24 January 2013 16:17:16 UTC