W3C home > Mailing lists > Public > public-html-media@w3.org > December 2013

[Bug 24117] New: "keys" and "setMediaKeys()" should be named consistently

From: <bugzilla@jessica.w3.org>
Date: Mon, 16 Dec 2013 20:08:46 +0000
To: public-html-media@w3.org
Message-ID: <bug-24117-5436@http.www.w3.org/Bugs/Public/>

            Bug ID: 24117
           Summary: "keys" and "setMediaKeys()" should be named
           Product: HTML WG
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Encrypted Media Extensions
          Assignee: adrianba@microsoft.com
          Reporter: ddorwin@google.com
        QA Contact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-media@w3.org

It's odd that we have "Media" and thus the full type (MediaKeys) in the setting
function ("setMediaKeys()") but not in the attribute ("keys"). They both
operate on the same type and reference the same underlying object.

We should either rename the attribute to "mediaKeys" or rename the method to

Using the full type name is nice, but "Media" is also redundant since these are
members of HTMLMediaElement.

You are receiving this mail because:
You are on the CC list for the bug.
Received on Monday, 16 December 2013 20:08:48 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:33:01 UTC