W3C home > Mailing lists > Public > public-html-media@w3.org > September 2012

Re: [EME] Bug 18531 - rename addKey method

From: Mark Watson <watsonm@netflix.com>
Date: Wed, 26 Sep 2012 16:02:33 +0000
To: "<public-html-media@w3.org>" <public-html-media@w3.org>
Message-ID: <F9FA5B5B-AB8D-45F8-A6C6-FDD7A43B45CC@netflix.com>
Last call for suggestions, otherwise we'll go with update().


On Sep 4, 2012, at 12:54 PM, Joe Steele wrote:

I like update() since this is hanging off of a MediaKeySession.

Joe Steele

On Sep 4, 2012, at 8:28 AM, Mark Watson wrote:


The addKey method can be used for more than just providing a key. Specifically
it can be used for
- providing a key
- providing a license
- updating a license or other CDM session state

As a result the addKey name is confusing.

In general, the purpose of this method is to provide a message to the CDM that
updates the session state in some CDM-specific way. With the object-oriented
model, sessions are explicitly represented by session objects and addKey is a
method on that object.

With that context we could rename the method to something simple.

Proposals so far:

- update() (as in update the session state)

- addData() (as in provide some information to the session)

Comments, preferences, other suggestions ?

Received on Wednesday, 26 September 2012 16:03:07 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:32:56 UTC