[MSE] Proposal to move SourceBufferList.remove() to MediaSource.removeSourceBuffer()

Hi,

I was talking to one of our engineers that is updating Chrome's MediaSource
implementation to the new object-oriented API and she requested changing
the spec so SourceBufferList.remove() is replaced by
MediaSource.removeSourceBuffer(). Here are a few reasons we think this
would be a good idea.

1. It feels more consistant to add and remove SourceBuffers through the
same object.
2. The MediaSource object has two SourceBufferList objects and it seems
weird to call remove() on one of them and that call modifying the other
list. (ie mediaSource.activeSourceBuffers.remove(sourceBuffer) would
trigger a change in mediaSource.sourceBuffers and vice-versa.)

If anyone has an objection please let me know. Otherwise I'll publish an
update to the spec sometime Friday afternoon.

Aaron

Received on Monday, 9 July 2012 21:32:07 UTC