W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > October 2013

[Bug 23427] New: Dialog element method names need to be aligned better.

From: <bugzilla@jessica.w3.org>
Date: Wed, 02 Oct 2013 18:43:16 +0000
To: public-html-bugzilla@w3.org
Message-ID: <bug-23427-2486@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=23427

            Bug ID: 23427
           Summary: Dialog element method names need to be aligned better.
           Product: HTML WG
           Version: unspecified
          Hardware: Macintosh
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML5 spec
          Assignee: dave.null@w3.org
          Reporter: ben@abmcd.com
        QA Contact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-admin@w3.org,
                    public-html-wg-issue-tracking@w3.org

"show()" and "close()" don't make a very obvious pair in terms of method names.
This is pretty bad from a semantics point of view.

How about show(), showModal() and hide() ? Or open(), openModal() and close() ?

I'm also not convinced of the value of show() on its own. What is there here
that can't be done better and more clearly with one line of jQuery, in terms of
form elements in the DOM

 The really useful part of this spec is the pending dialog stack. I think
"show()" should be axed, and "showModal()" should be renamed "open()".

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Wednesday, 2 October 2013 18:43:19 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 16:31:44 UTC