W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > July 2012

[Bug 17743] New: When setting designMode to 'on', the selection should be moved to an empty selection at the start of body (or something like that). If there isn't a body yet, wait until there is. Don't do this for contenteditable.

From: <bugzilla@jessica.w3.org>
Date: Wed, 11 Jul 2012 12:12:15 +0000
To: public-html-bugzilla@w3.org
Message-ID: <bug-17743-2486@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17743

           Summary: When setting designMode to 'on', the selection should
                    be moved to an empty selection at the start of body
                    (or something like that). If there isn't a body yet,
                    wait until there is. Don't do this for
                    contenteditable.
           Product: HTML WG
           Version: unspecified
          Platform: Other
               URL: http://www.whatwg.org/specs/web-apps/current-work/#mak
                    ing-entire-documents-editable:-the-designmode-idl-attr
                    ibute
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: other Hixie drafts (editor: Ian Hickson)
        AssignedTo: ian@hixie.ch
        ReportedBy: contributor@whatwg.org
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, simonp@opera.com


Specification:
http://www.whatwg.org/specs/web-apps/current-work/multipage/editing.html
Multipage:
http://www.whatwg.org/C#making-entire-documents-editable:-the-designmode-idl-attribute
Complete:
http://www.whatwg.org/c#making-entire-documents-editable:-the-designmode-idl-attribute

Comment:
When setting designMode to 'on', the selection should be moved to an empty
selection at the start of body (or something like that). If there isn't a body
yet, wait until there is. Don't do this for contenteditable.

Posted from: 2001:4c28:a030:30:3974:4eac:84c6:cfd6 by simonp@opera.com
User agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.7.3; U; en)
Presto/2.10.289 Version/12.00

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Wednesday, 11 July 2012 12:12:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 11 July 2012 12:12:21 GMT