W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > September 2011

[Bug 14210] New: Reflecting href with a URL that doesn't resolve doesn't return the empty string in browsers (at least opera/moz, don't know what URL would fail to resolve in webkit). Instead it returns the value without resolving.

From: <bugzilla@jessica.w3.org>
Date: Mon, 19 Sep 2011 06:49:20 +0000
To: public-html-bugzilla@w3.org
Message-ID: <bug-14210-2486@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=14210

           Summary: Reflecting href with a URL that doesn't resolve
                    doesn't return the empty string in browsers (at least
                    opera/moz, don't know what URL would fail to resolve
                    in webkit). Instead it returns the value without
                    resolving.
           Product: HTML WG
           Version: unspecified
          Platform: Other
               URL: http://www.whatwg.org/specs/web-apps/current-work/#ref
                    lecting-content-attributes-in-idl-attributes
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: HTML5 spec (editor: Ian Hickson)
        AssignedTo: ian@hixie.ch
        ReportedBy: contributor@whatwg.org
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-wg-issue-tracking@w3.org,
                    public-html@w3.org, simonp@opera.com


Specification:
http://www.whatwg.org/specs/web-apps/current-work/complete/common-dom-interfaces.html
Multipage:
http://www.whatwg.org/C#reflecting-content-attributes-in-idl-attributes
Complete:
http://www.whatwg.org/c#reflecting-content-attributes-in-idl-attributes

Comment:
Reflecting href with a URL that doesn't resolve doesn't return the empty
string in browsers (at least opera/moz, don't know what URL would fail to
resolve in webkit). Instead it returns the value without resolving.

Posted from: 85.227.155.223 by simonp@opera.com
User agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.5.8; U; en) Presto/2.9.168
Version/11.51

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 19 September 2011 06:49:26 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 16:31:19 UTC