W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > October 2009

[Bug 8019] New: <!DOCTYPE html PUBLICa> throws two parse errors.

From: <bugzilla@wiggum.w3.org>
Date: Fri, 23 Oct 2009 09:37:55 +0000
To: public-html-bugzilla@w3.org
Message-ID: <bug-8019-2486@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8019

           Summary: <!DOCTYPE html PUBLICa> throws two parse errors.
           Product: HTML WG
           Version: unspecified
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML5 spec bugs
        AssignedTo: dave.null@w3.org
        ReportedBy: geoffers+w3cbugs@gmail.com
         QAContact: public-html-bugzilla@w3.org
                CC: ian@hixie.ch, mike@w3.org, public-html@w3.org


<!DOCTYPE html PUBLICa> throws two parse errors at the "a", and, similarly,
<!DOCTYPE html SYSTEMa> throws two parse errors at the "a".

To fix this:

Firstly, add a case for U+0022 and U+0027 in after DOCTYPE public/system
keyword states, which says: "Parse error. Reconsume the current character in
the before DOCTYPE public/system identifier state."

Secondly, remove the "Parse error." from the Anything else case in both the
after DOCTYPE public/system keyword states.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 23 October 2009 09:37:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 23 October 2009 09:37:57 GMT