W3C home > Mailing lists > Public > public-html-a11y@w3.org > December 2011

[Bug 13096] Enhancement: Set single component for pixel

From: <bugzilla@jessica.w3.org>
Date: Fri, 02 Dec 2011 08:32:58 +0000
To: public-html-a11y@w3.org
Message-Id: <E1RWOYE-0003fN-MH@jessica.w3.org>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=13096

j.chetwynd <j.chetwynd@btinternet.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |

--- Comment #3 from j.chetwynd <j.chetwynd@btinternet.com> 2011-12-02 08:32:57 UTC ---
#2 perhaps "Set single component for pixel" and  "each component can be
independently set." are not clear?

as I understand it putImageData() requires alpha and RGB color to be set for
each pixel.

this bug proposes that a single component such as alpha might be set.
and thus not requiring the other three components to be set (again) at the same
time.

the issue is that where only one of the four is being manipulated processing
time could be accelerated, on large full screen images of many megabytes.

apologies if I misunderstand the situation.

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Friday, 2 December 2011 08:33:00 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:05:25 UTC