W3C home > Mailing lists > Public > public-html-a11y@w3.org > March 2010

Re: Survey ready on Media Multitrack API proposal

From: Silvia Pfeiffer <silviapfeiffer1@gmail.com>
Date: Sun, 7 Mar 2010 12:45:40 +1100
Message-ID: <2c0e02831003061745v140bed59ida12fb71853da96@mail.gmail.com>
To: Eric Carlson <eric.carlson@apple.com>
Cc: Philip Jägenstedt <philipj@opera.com>, "Michael(tm) Smith" <mike@w3.org>, HTML Accessibility Task Force <public-html-a11y@w3.org>
On Sun, Mar 7, 2010 at 12:32 PM, Eric Carlson <eric.carlson@apple.com> wrote:
>
> On Mar 6, 2010, at 2:42 PM, Silvia Pfeiffer wrote:
>
> I don't think we need to make it this complicated.
>
> If I understand it correctly, in MPEG, track groups are built by
> giving each track of the same group the same identifier. This could
> just be replicated in the JavaScript API:
>
> interface MediaTrack {
> ...
>  readonly attribute DOMString groupname;
> ...
> }
>
> Then the functions of getting all tracks that belong to the same group
> can be built as convenience functions on top of this one attribute.
>
> Seeing as the majority of use cases will not include grouping (e.g. I
> wasn't able to find a single MPEG file that has track groups), this
> simpler JavaScript API looks preferable to me and will be easier to
> deal with for a script author IMHO.
>
>   I agree that we should not make this overly complicated and I agree with
> your suggestion generally, but I think "groupId" would be a better name for
> the attribute than "groupname".  Alternate group in ISO and QuickTime files
> is an integer, and while it may be a string in other container formats I
> don't think we should imply that the attribute is anything but an
> identifier.
> eric
>

OK, agreed.

Silvia.
Received on Sunday, 7 March 2010 01:46:32 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 27 April 2012 04:42:03 GMT