W3C home > Mailing lists > Public > public-geolocation@w3.org > March 2010

Re: enableHighAccuracy as a privacy feature

From: Andrei Popescu <andreip@google.com>
Date: Fri, 26 Mar 2010 16:14:59 +0000
Message-ID: <708552fb1003260914s578f67cdvd547a361d219e8f1@mail.gmail.com>
To: Dominique Hazael-Massieux <dom@w3.org>
Cc: Lars Erik Bolstad <lbolstad@opera.com>, Matt Womer <mdw@w3.org>, Aaron Boodman <aa@google.com>, Doug Turner <dougt@dougt.org>, "Thomson, Martin" <Martin.Thomson@andrew.com>, public-geolocation <public-geolocation@w3.org>
On Fri, Mar 26, 2010 at 4:08 PM, Dominique Hazael-Massieux <dom@w3.org> wrote:
> Le vendredi 26 mars 2010 à 15:06 +0000, Andrei Popescu a écrit :
>> - this attribute has always been about saving power, not about
>> accuracy. The assumption was that the more power a sensor consumes,
>> the more accurate it is.
>
> http://lists.w3.org/Archives/Public/public-geolocation/2009Mar/0160.html
> (last linked message from
> http://www.w3.org/2008/geolocation/track/issues/6) says:
>        "The main reason why it exists is to allow Web developers to say
>        that their application works fine with low-accuracy position
>        fixes and, therefore, the UA should not bother turning on
>        location providers that consume a lot of power"
>
> I guess my point is that if an application "works fine with low-accuracy
> position fixes", then it's better not to send high-accuracy position
> data, since that's a benefit for privacy.
>

Well, the same emails also says:

"Web developers care about power consumption
since, on mobile devices especially, this has an impact on how long
their applications can be used. So how about renaming this attribute
to "lowPowerOnly" (thanks to Steve Block for the suggestion) ? This
name is closer to the intended effect: a hint that the implementation
should make use of only what it considers to be low power providers.
What is a low power provider is left to the implementation to decide,
but a reasonable course of action would be to avoid powering up the
GPS when "lowPowerOnly" attribute is set to true."

So that's the context: power saving, not privacy. If the attribute had
the better name of "lowPowerOnly", would you be making the same
suggestion?

Thanks,
Andrei
Received on Friday, 26 March 2010 16:15:47 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 22 March 2012 18:13:46 GMT