Re: renaming enableHighAccuracy

Sounds reasonable to me.


Andrei Popescu wrote:
> Hi,
> 
> The 'enableHighAccuracy' attribute continues to generate a lot of
> controversy so I'd like to propose renaming it.
> 
> The main reason why it exists is to allow Web developers to say that
> their application works fine with low-accuracy position fixes and,
> therefore, the UA should not bother turning on location providers that
> consume a lot of power. Web developers care about power consumption
> since, on mobile devices especially, this has an impact on how long
> their applications can be used. So how about renaming this attribute
> to "lowPowerOnly" (thanks to Steve Block for the suggestion) ? This
> name is closer to the intended effect: a hint that the implementation
> should make use of only what it considers to be low power providers.
> What is a low power provider is left to the implementation to decide,
> but a reasonable course of action would be to avoid powering up the
> GPS when "lowPowerOnly" attribute is set to true.
> 
> Thanks,
> Andrei
> 
> 

Received on Tuesday, 31 March 2009 18:12:50 UTC