Re: [geometry] Name of DOMMatrix and related classes is out of place.

On Tue, 03 Nov 2015 20:42:51 +0100, /#!/JoePea <trusktr@gmail.com> wrote:

> On Tue, Nov 3, 2015 at 2:23 AM, Simon Pieters <simonp@opera.com> wrote:
>
>>
>> * I think the name should be consistent between the various interfaces  
>> in
>> the Geometry spec.

I think you need to consider this point and not just focus on DOMMatrix.  
What if WebGL or 2d canvas decide to expose DOMQuads or DOMPoints?

>> * We can't use no prefix at all because Web content already uses  
>> "Point",
>> "Matrix", etc.
>
> * "DOM" is typically understood to include everything that is defined in
>> terms of WebIDL these days, not just the objects that are descendants of
>> window.document.
>
>
> ​"Document Object Model"​ isn't something you'll find inside WebGL.

I didn't claim you would. I claim that WebGL is typically understood to be  
included in the "DOM" part of the Web platform, as is e.g. WebSocket. I  
don't have data to back it up though and I know that not everyone agree on  
this point.

> * "DOMString" is a name that is used for all strings in the Web platform,
>> and this hasn't been a problem in practice (although that name is not
>> visible to JS).
>
>
> ​True, but DOMMatrix *will* be visible.​

Yes. I suggest it is not going to be a problem in practice.

>> * The common interactions with DOMMatrix will not involve touching the  
>> name
>> itself, but more use methods called e.g. "transformMatrix" and so on.
>
>> * These names have been bikeshedded in the past, where we concluded that
>> "DOM" prefix was least bad (it's short, globally applicable).
>
>
>> All in all, I agree that it's not ideal (I would have preferred no  
>> prefix
>> if the Web hadn't claimed the names), but I'm not convinced that it is a
>> good idea to change the name of DOMMatrix at this point. In particular,  
>> I
>> disagree that the name is inappropriate for 2d canvas or WebGL.
>
>
> ​Apparently, ​"GraphicalMatrix" isn't taken whatsoever:
> https://github.com/search?q=GraphicalMatrix+language%3Ajavascript&type=Code
>
> "AffineMatrix" isn't used much:
> https://github.com/search?q=AffineMatrix+language%3Ajavascript&ref=searchresults&type=Code
>
> "AffineTransformMatrix" has zero usage:
> https://github.com/search?q=AffineTransformMatrix+language%3Ajavascript&type=Code
>
> "GraphicalTransformMatrix" has also has zero usage:
> https://github.com/search?q=GraphicalTransformMatrix+language%3Ajavascript&type=Code

The problem at this point is not really finding a better name (though  
personally I think all of those are worse because they are longer and so  
more annoying to type). The problem is that these names have shipped, so  
you need to convince the relevant browser vendors to change the name. If  
browsers do change the name, the spec will be updated to match what is  
implemented.

Also see
https://lists.w3.org/Archives/Public/www-style/2013Sep/0751.html
https://lists.w3.org/Archives/Public/public-script-coord/2013JulSep/0670.html

cheers
-- 
Simon Pieters
Opera Software

Received on Monday, 9 November 2015 11:35:56 UTC