W3C home > Mailing lists > Public > public-fx@w3.org > January to March 2013

Re: comments on Matrix

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Fri, 22 Mar 2013 09:18:03 -0700
Message-ID: <CAAWBYDDSdaUPdie=sYuoeeZL6fsoP8=H_es8Gb5GGiyeN3rZZw@mail.gmail.com>
To: Benoit Jacob <jacob.benoit.1@gmail.com>
Cc: "public-fx@w3.org" <public-fx@w3.org>
On Fri, Mar 22, 2013 at 4:48 AM, Benoit Jacob <jacob.benoit.1@gmail.com> wrote:
> The following points don't seem to have been discussed yet:
> 2013/3/19 Benoit Jacob <jacob.benoit.1@gmail.com>
>> 4. Some method names are verbs, yet they do not perform an action on their
>> object. Example: translate(). I would call that translated(), I suppose.

I'd like more input from JS design people on this point.  I like
having a convention for knowing when an operation is pure or mutating,
and I know that Python used the "past tense verb" convention for that
in some places, but I don't think JS has such a convention so far.
However, if we plan to add mutating methods in the future, it's very
reasonable to think about this now.

Received on Friday, 22 March 2013 16:18:54 UTC

This archive was generated by hypermail 2.3.1 : Monday, 22 June 2015 03:33:49 UTC