W3C home > Mailing lists > Public > public-forms@w3.org > April 2012

Re: Supporting AVTs in bind and model attributes

From: Nick Van den Bleeken <Nick.Van.den.Bleeken@inventivegroup.com>
Date: Wed, 18 Apr 2012 14:23:43 +0000
To: John Boyer <boyerj@ca.ibm.com>
CC: Public Forms <public-forms@w3.org>, "public-xformsusers@w3.org" <public-xformsusers@w3.org>
Message-ID: <905DFA52-EAC8-4246-82AF-88BDE1112468@inventivegroup.com>
Thanks John, that slipped my mind, then I will mark those as not supporting AVTs and this will cause an error because curly brackets aren't allowed in an IDREF.

Kind regards,

Nick Van den Bleeken
R&D Manager

Phone: +32 3 425 41 02
Office fax: +32 3 821 01 71
nick.van.den.bleeken@inventivegroup.com<mailto:nick.van.den.bleeken@inventivegroup.com>
www.inventivedesigners.com


[cid:image001.png@01CBF2F8.1DA19110][cid:image002.png@01CBF2F8.1DA19110][cid:image003.png@01CBF2F8.1DA19110]

On 18 Apr 2012, at 16:17, John Boyer wrote:

Hi Nick,

I think we agreed previously to just call those out as binding exceptions for now.

Cheers,
John M. Boyer, Ph.D.
Distinguished Engineer, IBM Forms and Smarter Web Applications
IBM Canada Software Lab, Victoria
E-Mail: boyerj@ca.ibm.com<mailto:boyerj@ca.ibm.com>

Twitter: http://twitter.com/johnboyerphd
Blog: http://www.ibm.com/developerworks/blogs/page/JohnBoyer
Blog RSS feed: http://www.ibm.com/developerworks/blogs/rss/JohnBoyer?flavor=rssdw





From:        Nick Van den Bleeken <Nick.Van.den.Bleeken@inventivegroup.com<mailto:Nick.Van.den.Bleeken@inventivegroup.com>>
To:        Public Forms <public-forms@w3.org<mailto:public-forms@w3.org>>
Cc:        "public-xformsusers@w3.org<mailto:public-xformsusers@w3.org>" <public-xformsusers@w3.org<mailto:public-xformsusers@w3.org>>
Date:        18/04/2012 03:45 AM
Subject:        Supporting AVTs in bind and model attributes
________________________________



Hi,

Do we want to support AVTs in bind and model attributes? This will require some rewiring of UI controls if their value changes. And even cause exceptions because a custom function isn't available in the new model if the value of the model attribute changes.

Kind regards,

Nick Van den Bleeken
R&D Manager

Phone: +32 3 425 41 02
Office fax: +32 3 821 01 71
nick.van.den.bleeken@inventivegroup.com<mailto:nick.van.den.bleeken@inventivegroup.com>
www.inventivedesigners.com


<Mail Attachment.png><Mail Attachment.png><Mail Attachment.png>


________________________________

Inventive Designers' Email Disclaimer:
http://www.inventivedesigners.com/email-disclaimer

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.


________________________________

Inventive Designers' Email Disclaimer:
http://www.inventivedesigners.com/email-disclaimer



image001.png
(image/png attachment: image001.png)

image002.png
(image/png attachment: image002.png)

image003.png
(image/png attachment: image003.png)

Received on Wednesday, 18 April 2012 14:28:42 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 October 2013 22:06:56 UTC