W3C home > Mailing lists > Public > public-esw-thes@w3.org > July 2008

Re: Why not a generic skos:label datatype property? Re: Southampton Pub data as linked open data

From: Bijan Parsia <bparsia@cs.man.ac.uk>
Date: Wed, 30 Jul 2008 04:10:38 +0100
Message-Id: <ABA5C0C1-25AB-4052-BBAD-02622F85E1E6@cs.man.ac.uk>
Cc: Tim Berners-Lee <timbl@w3.org>, Richard Cyganiak <richard@cyganiak.de>, John Goodwin <John.Goodwin@ordnancesurvey.co.uk>, public-lod@w3.org, semantic-web@w3.org, SKOS <public-esw-thes@w3.org>
To: Bernard Vatant <bernard.vatant@mondeca.com>

On Jul 29, 2008, at 3:42 PM, Bernard Vatant wrote:
[snip]
> Recommending systems built on the semantics of OWL, which are quite  
> hard to set up and define properly, to ignore parts of this very  
> semantics sounds to me as a strange recommendation coming from the  
> very W3C top :-)
>
> But : as said before, the real issue is that you ask both  
> vocabulary publishers and implementers to hack the standards  
> semantics, default any proper way in those standards to deal with  
> names.
> What I suggest here (with cc to SKOS forum)  is to define somewhere  
> a standard generic label datatype property, which could be easily  
> refined in specific types of labels while keeping in OWL-DL; making  
> everybody happy. The most natural place to do that seems to be SKOS  
> namespace.
> Here is the proposal
>
> skos:label      a    owl:DatatypeProperty
> skos:prefLabel      rdfs:subPropertyOf      skos:label
> skos:altLabel      rdfs:subPropertyOf      skos:label
> ...
> pub:name     rdfs:subPropertyOf      skos:label

[snip]

I think considering a nice set of label properties is a good idea.

I'd like it if we considered various mechanisms for describing them  
as well as opposed to the subproperty trick. (Some variant of which,  
of course, can be made to work in OWL esp. in OWL 2. I'm happy to  
push for extra things in OWL 2 to accommodate this better.)

(For example, one thing that seems like it would be really useful is  
to designate fallbacks. alt:label seems like one, but wouldn't it be  
better to be able to say something like: display the label, if  
present, then the altLabel, if these are missing then use the string  
after the hash of the uri or the content of the property "name".)

(Given the commonality of certain uri naming conventions, we might go  
even further. E.g., define certain parsing for hasFoo.)

Cheers,
Bijan.
Received on Wednesday, 30 July 2008 03:11:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:39:00 GMT