W3C home > Mailing lists > Public > public-esw-thes@w3.org > January 2005

SKOS 'Collections'

From: Miles, AJ \(Alistair\) <A.J.Miles@rl.ac.uk>
Date: Mon, 31 Jan 2005 12:14:55 -0000
Message-ID: <F5839D944C66C049BDB45F4C1E3DF89D18DB66@exchange31.fed.cclrc.ac.uk>
To: "Mark van Assem" <mark@cs.vu.nl>, <public-esw-thes@w3.org>

Mark wrote:
> What is the motivation to use a separate Collection vocabulary instead
> of the standard RDF vocabulary? Does that have something to 
> do with the
> special rules that are introduced for them (collectable 
> property rule)?

This discussion relates to the following skos classes and properties:

skos:Collection
skos:OrderedCollection
skos:CollectableProperty
skos:member
skos:memberList

The initial requirement and some early possible solutions are presented with discussion at:

http://esw.w3.org/topic/SkosDev_2fSkosCore_2fCollectionsAndArrays

... N.B. the solutions discussed here are precursors of the actual solution we acted on (see [1] for fonal proposal).

Basically we opted against using rdf:Bag and rdf:Seq, because nobody likes them (see also emails linked from pros & cons section in above).

Anyway, I'd like to propose that we keep the basic structure of this bit of SKOS Core the same for the moment.

However I am concerned about the use of the name 'Collection' because it collides both with the RDF notion of a 'Collection' and the libraries/museum's notion of a 'Collection'.  I have also seen the property 'skos:member' completely misconstrued.  So I'd like to propose that we change the names of these props to something like:

skos:ConceptGroup
skos:OrderedConceptGroup
skos:GroupableProperty
skos:groupMember
skos:groupMemberList  

How does that sound?

Cheers,

Al.

[1] http://lists.w3.org/Archives/Public/public-esw-thes/2004Oct/0072.html
Received on Monday, 31 January 2005 12:15:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:38:53 GMT