W3C home > Mailing lists > Public > public-device-apis@w3.org > November 2012

Re: [capture] keywords (was: Agenda)

From: fantasai <fantasai.lists@inkedblade.net>
Date: Tue, 27 Nov 2012 14:01:19 -0800
Message-ID: <50B5382F.8080202@inkedblade.net>
To: Frederick.Hirsch@nokia.com
CC: tobie@fb.com, anssi.kostiainen@nokia.com, nn.murthy@cmcltd.com, public-device-apis@w3.org
On 11/27/2012 12:51 PM, Frederick.Hirsch@nokia.com wrote:
> Tobie
>
> I don't understand why it *should* be a boolean simply because we have
> 'camera' to indicate device still image capture for a variety of devices
> (let's ignore audio for now, as that is a different case)

Because the extent to which the values currently are distinct is
already handled, and should therefore be expressed, by the 'accept'
attribute.

If you want to be more specific later on, you can extend the boolean
to take a list or something, and indicate preferences:
   capture='front-camera, back-camera, scanner, camcorder'

But as for right now, you're just duplicating type information, and
are therefore afaict better off just making it a boolean. It's easier
to use, encourages people to put correct 'accept' values, and avoids
even the possibility of mismatched values for 'capture' and 'accept'.

~fantasai
Received on Tuesday, 27 November 2012 22:01:50 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 14:53:56 UTC