W3C home > Mailing lists > Public > public-device-apis@w3.org > November 2009

Re: [FileReader API, ProgressEvents] Design patterns, FileWriter API

From: Robin Berjon <robin@robineko.com>
Date: Wed, 18 Nov 2009 12:23:33 +0100
Cc: arun@mozilla.com, "Marcin Hanclik" <Marcin.Hanclik@access-company.com>, "WebApps WG" <public-webapps@w3.org>, "public-device-apis@w3.org" <public-device-apis@w3.org>
Message-Id: <2ECAB527-AEB1-41FC-8033-536BFD8BDB00@robineko.com>
To: Anne van Kesteren <annevk@opera.com>
On Nov 18, 2009, at 10:30 , Anne van Kesteren wrote:
On Wed, 18 Nov 2009 02:30:16 +0100, Arun Ranganathan <arun@mozilla.com> wrote:
>> I think that just as the names 'load*' were chosen for generic data transfer events (either networked or within a document), and are used within documents loaded in the DOM, XHR, and FileReader, we'll need reusable 'write*' events.  Without bikeshedding too much, I like your proposal above, but wonder whether we should use the name 'write*' or something else.  Since we already have document.write, 'write' is probably the most vetted string to use here :)
> 
> For what it's worth, for XMLHttpRequest "sending" events (which are arguably somewhat like write) we still use loadstart/... and simply dispatch them on a distinct object. I've no idea what the file writer API will look like, but I can imagine we might be able to do the same there.

Yes, that's what I would expect too. We've been down this road of trying to change event names to reflect the reality of their triggering, and last time around we found that it was better to change the definition and keep the name rather than change the name. And since we're using consistency with XHR for File, we should use load events in the same manner.

--
Robin Berjon
  robineko  hired gun, higher standards
  http://robineko.com/
Received on Wednesday, 18 November 2009 11:24:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 00:14:01 GMT