W3C home > Mailing lists > Public > public-device-apis-log@w3.org > July 2019

Re: [deviceorientation] DeviceMotion only works once at init and return null value (#77)

From: NjnuTZhou via GitHub <sysbot+gh@w3.org>
Date: Fri, 19 Jul 2019 01:35:16 +0000
To: public-device-apis-log@w3.org
Message-ID: <issue_comment.created-513055130-1563500114-sysbot+gh@w3.org>
Thank you for your reply!
This behaviour appeared when I tested it in my phone(vivo X9S plus).However, When i used DeviceOrientation it returns specific value. Besides, my phone returns specific result using cordova-plugin-device-motion plugin.
I have checked hardware in my phone, and it does have gyroscope and Accelerometer. Soit may not be the platform's probelm?
Thank you!




------------------ 原始邮件 ------------------
发件人: "Reilly Grant"<notifications@github.com>;
发送时间: 2019年7月19日(星期五) 凌晨0:27
收件人: "w3c/deviceorientation"<deviceorientation@noreply.github.com>;
抄送: "咖啡糖,甜蜜"<1084146755@qq.com>;"Author"<author@noreply.github.com>;
主题: Re: [w3c/deviceorientation] DeviceMotion only works once at init andreturn null value  (#77)




This is the specified behavior when the platform does not have device motion sensors. If you think it should be working on your device please file an issue against the browser you are testing with. This repository is just the specification.
 
—
You are receiving this because you authored the thread.
Reply to this email directly, view it on GitHub, or mute the thread.

-- 
GitHub Notification of comment by NjnuTZhou
Please view or discuss this issue at https://github.com/w3c/deviceorientation/issues/77#issuecomment-513055130 using your GitHub account
Received on Friday, 19 July 2019 01:35:18 UTC

This archive was generated by hypermail 2.3.1 : Friday, 19 July 2019 01:35:19 UTC