W3C home > Mailing lists > Public > public-ddwg-comments@w3.org > May 2008

Re: Your comments on Device Description Repository Simple API ( LC-1974)

From: <rotan.hanrahan@mobileaware.com>
Date: Wed, 14 May 2008 15:04:48 +0000
To: (wrong string) é Manuel Cantera <jmcf@tid.es>
Cc: public-ddwg-comments@w3.org
Message-Id: <E1JwIXA-00036q-Ud@farnsworth.w3.org>

 Dear José Manuel Cantera ,

The Mobile Web Initiative Device Description Working Group has reviewed
the comments you sent [1] on the Last Call Working Draft [2] of the Device
Description Repository Simple API published on 4 Apr 2008. Thank you for
having taken the time to review the document and to send us comments!

The Working Group's response to your comment is included below, and has
been implemented in the new version of the document available at:

Please review it carefully and let us know by email at
public-ddwg-comments@w3.org if you agree with it or not before 24 May
2008. In case of disagreement, you are requested to provide a specific
solution for or a path to a consensus with the Working Group. If such a
consensus cannot be achieved, you will be given the opportunity to raise a
formal objection which will then be reviewed by the Director during the
transition of this document to the next stage in the W3C Recommendation


For the Mobile Web Initiative Device Description Working Group,
Matt Womer
W3C Staff Contact

 2. http://www.w3.org/TR/2008/WD-DDR-Simple-API-20080404/


Your comment on :
> Regarding the getAPIVersion method and provided that the method is not
> finally removed,
> It should be differentiated between the version of the API and the
> version of the implementation.
> As this method returns information about the version of the
> implementation, it should be called "getVersion" and not
> getAPIVersion.
> Proposed amendment:
> Rename getAPIVersion to getVersion()
> ======
> Follow up from Commenter:
> Regarding the getAPIVersion() method,
> What are the envisioned use cases for that method?
> Proposed amendment
> If there are no relevant use cases for the method, it should be removed

Working Group Resolution (LC-1974):
The DDWG has resolved to change the name of getAPIVersion to
getImplementationVersion and include an explanation mentioning the use in
diagnostics across all languages.

Received on Wednesday, 14 May 2008 15:05:26 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:41:40 UTC