W3C home > Mailing lists > Public > public-cwm-talk@w3.org > October to December 2008

Re: EulerGUI - a light-weight N3 IDE - open source

From: Jean-Marc Vanel <jeanmarc.vanel@gmail.com>
Date: Sat, 1 Nov 2008 09:46:45 +0100
Message-ID: <e0320dfa0811010146w2533dacbvd107d32cda350e7d@mail.gmail.com>
To: "Chimezie Ogbuji" <chimezie@gmail.com>
Cc: public-cwm-talk@w3.org

2008/10/31 Chimezie Ogbuji <chimezie@gmail.com>:
> Hello, Jean-Marc.  As you can imagine, I'm quite anxious to use your
> tool (there are little to no N3 editors out there that I know of)?
> However, when I tried to run the EulerGUI jar file (version 3 and 2),
> I get the following error on my Mac OSX laptop:
>
> bash-3.2$ java -jar ~/EulerGui/eulergui3.jar
> Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad
> version number in .class file
>        at java.lang.ClassLoader.defineClass1(Native Method)
>        at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
>        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
> bash-3.2$ java -version
> java version "1.5.0_16"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
> Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing)
>
> Any ideas?

Sorry, this is a typical Java bothering.
I should have added in the documentation that one must install a
Java(TM) 2 Runtime Environment (JRE), Standard Edition version 1.6
from http://java.sun.com

You can keep your JRE 1.5 , but generally older applications compiled
for 1.5 run well on JRE 1.6 ,
but not the converse.

I'm updating the doc. right now.

Happy designing with EulerGUI.

-- 
Jean-Marc Vanel
http://jmvanel.free.fr/
Received on Saturday, 1 November 2008 08:47:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 1 November 2008 08:47:30 GMT