W3C home > Mailing lists > Public > public-css-testsuite@w3.org > July 2005

Re: Error in Test t040304-c64-uri-00-a-g

From: Ian Hickson <ian@hixie.ch>
Date: Sat, 2 Jul 2005 13:14:22 +0000 (UTC)
To: Lachlan Hunt <lachlan.hunt@lachy.id.au>
Cc: public-css-testsuite@w3.org
Message-ID: <Pine.LNX.4.61.0507021312180.11931@dhalsim.dreamhost.com>

On Sat, 2 Jul 2005, Lachlan Hunt wrote:
>
>   I believe there is a mistake in these tests:
> http://www.w3.org/Style/CSS/Test/CSS2.1/current/t040304-c64-uri-00-a-g.htm
> http://www.w3.org/Style/CSS/Test/CSS2.1/current/t040304-c64-uri-00-a-g.xht
> 
> The two stylesheets being imported contain the errors.
> http://www.w3.org/Style/CSS/Test/CSS2.1/current/support/css1test64a.css
> http://www.w3.org/Style/CSS/Test/CSS2.1/current/support/css1test64b.css
> 
> css1test64a.css contains:
> p.one {background: red url(support/swatch-red.png);color:white;}
> 
> It should have a green background, since the request for swatch-red.png should
> result in a 404 Not Found

No, it shouldn't. It should result in downloading

   http://www.w3.org/Style/CSS/Test/CSS2.1/current/support/support/swatch-red.png

...which is a green image.

Unfortunately, however, it appears that that file failed to get uploaded. 
I'll look into it. In the meantime you can see the working copy of the 
tests here:

   http://www.hixie.ch/tests/evil/css/css21/tests/t040304-c64-uri-00-a-g.htm
   http://www.hixie.ch/tests/evil/css/css21/tests/t040304-c64-uri-00-a-g.xht

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Saturday, 2 July 2005 13:14:33 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 20 September 2010 17:51:54 GMT