Re: [csswg-drafts] [css-nav-1] Improve the name of window.navigate (#3387)

@zcorpan @AmeliaBR Thank you for your opinions!

>  spatial navigation starting point (and/or sequential focus navigation starting point) should be exposed as an object that is a subclass of Range

Interesting idea! Exposing spatial navigation starting point (and/or sequential focus navigation starting point) as an object may be useful because sometimes those aren't the same with `document.activeElement`.

However, `window.navigate()` intends to provide a way to simulate spatial navigation **_simple_** for the author.
So, I wonder if there is a more intuitive way to do this than using spatial navigation starting point object.

> etc. And then you can get the current spatial navigation starting point with an attribute on window (if that is the appropriate place to put it?).

I have thought the similar thing about this!
I'm thinking about `spatialNavigation` object which can be referenced as an attribute of the Window interface.
The `spatialNavigation` object provides an interface for manipulating spatial navigation.
When we have this, `window.navigate()` may be changed to 
`window.spatialNavigation.explore(dir)` or `window.spatialNavigation.browse(dir)`.
(Thank you @AmeliaBR for the potential names!)

What do you think about this idea? (+ @frivoal)

> I agree that "navigate" is problematic, because of its potential for confusion with Navigator and URL navigation.
Indeed.

> Throwing out some potential names (forgive me if these have previously been discussed & discarded):
I also like `explore` among the candidates. 
But I'm bit worried about omitting the meaning of "directional" navigation.

-- 
GitHub Notification of comment by jihyerish
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/3387#issuecomment-496470320 using your GitHub account

Received on Tuesday, 28 May 2019 11:05:14 UTC