public-browser-tools-testing@w3.org from April to June 2014 by subject

[Bug 20860] WebDriver Level 1

[Bug 23869] Describe httpOnly more clearly

[Bug 23950] New status code "invalid argument"

[Bug 24132] getElementPosition is not in the spec

[Bug 24924] Inconsistent names in screenshot capabilities

[Bug 24932] The style of Section 4.1 is widely different than the style for the other sections describing commands

[Bug 24974] The distinction between Capabilities and MutableCapabilities is not useful in the context of this spec

[Bug 24978] Section 10.3.1 doesn't specify the exact color format to which implementation should transform style

[Bug 24979] The spec is missing section about switching to modal dialog

[Bug 24980] Incorrect link for selectable

[Bug 24987] Should window resizing and positioning methods take a windowHandle

[Bug 24990] Defining List of WebElement seems unnecessary

[Bug 25022] [WebDriver Spec]: Need to add a 'no such session' status code

[Bug 25059] Web IDL doesn't seem to have "number" type

[Bug 25063] Incorrect wording in section 7.3.1

[Bug 25064] 11.1 - Argument isn't allowed to be null/dictionary/array

[Bug 25068] Cookie lacks secure and max-age attribute

[Bug 25095] [WebDriver Spec]: getTitle is not documented

[Bug 25148] Provide ability to change a mutable capability value "on the fly"

[Bug 25165] 10.3.1 - Webdriver spec doesn't define getElementText

[Bug 25182] Should element with 0 clientWidth and clientHeight be considered visible?

[Bug 25183] 10.1 - IMO it's not needed to say that "unless the element is a text node" as element can't be text node

[Bug 25184] 10.1 - Use "element has hidden attribute" instead of "element is hidden"

[Bug 25285] New: Boolean attributes return null in both situations - if browser returns undefined and if browser returns false

[Bug 25286] New: Define whether pixel-based operations occur using device pixels or CSS reference pixels

[Bug 25293] New: Touch gestures API doesn't provide a way to do slow swipe

[Bug 25306] New: [WebDriver Spec]:unicode whitespace character class are seen in the current webdriver spec

[Bug 25307] New: [WebDriver Spec]: 10.4 effective CSS whitespace style needs to be defined

[Bug 25308] New: [WebDriver Spec]: 10.4 What language information should be considered for text-transform

[Bug 25317] New: Touch gestures API marks some high-level methods as low level one

[Bug 25318] New: It's not clear why wait is nullable and optional

[Bug 25331] 1.1 - "It is not intended as light bed time reading."

[Bug 25331] New: 1.1 - "It is not intended as light bed time reading."

[Bug 25332] 1.4 - keyword "OPTIONALLY" isn't actually used in the spec

[Bug 25332] New: 1,4 - keyword "OPTIONALLY" isn't really used in the specification

[Bug 25333] 2.1, 2,2 - sessionId/name/value are not marked as nullable

[Bug 25333] New: 2.1, 2,2 - sessionId/name/value are not marked as nullable

[Bug 25418] New: [WebDriver Spec]: Should we be pushing the use of vendor prefixes for extensions?

[Bug 25490] New: [WebDriver Spec]: Section 5.1.1 Constants - Conservative and Normal have the same behaviour

[Bug 25664] New: Nit: DOMString is never defined

[Bug 25664] Nit: DOMString is never defined

[Bug 25668] New: Nit: Capabilities.has spec can be simplified

[Bug 25668] Nit: Capabilities.has spec can be simplified

[Bug 25676] New: getWindowSize doesn't tell that it returns outerWidth/outerHeight

[Bug 25678] New: 7.2.1 - switchToWindow doesn't tell that it should change window focus

[Bug 25680] Don't tell what User Agent MUST do

[Bug 25680] New: Don't tell what User Agent MUST do

[Bug 25681] New: No "if Javascript is enabled"

[Bug 25681] No "if Javascript is enabled"

[Bug 25682] New: MAP does not use an image

[Bug 25687] New: Remove "perform" in actions as spec doesn't care about local end API

[Bug 25689] DOM-Level-3-Events spec doesn't describe how trusted events should be created

[Bug 25689] New: DOM-Level-3-Events spec doesn't describe how trusted events should be created

[Bug 25690] New: 14.2.1 - clickAndHoldAction/moveMouseAction/buttonReleaseAction are not defined

[Bug 25691] New: WebIDL operations for sending a sequence of MouseAction/TouchAction/MultiAction is not defined

[Bug 25692] 16 - It's not told what should happen if element is not passed to "takeScreenshot"

[Bug 25692] New: It's not told what should happen if element is not supplied

[Bug 25694] New: 16.2 section isn't needed as it's possible to take screenshot of "html"/"body"

[Bug 25695] New: 14.3.3 - sendKeys are low level commands

[Bug 25698] 14.3.3 - what is "activeElement"?

[Bug 25698] New: 14.3.3 - what is "activeElement"?

[Bug 25728] New: element.scrollIntoView should take implement scrolling animation

[Bug 25736] "Determining if an element is displayed" section: consistent use of "displayed", "shown", "visible", MUST

[Bug 25736] New: "Determining if an element is displayed" section: consistent use of "displayed", "shown", "visible", MUST

[Bug 25746] New: 14.3.3 - how should remote end determine current keyboard locale?

[Bug 25748] 15.1 - Alerts#getText should raise an error if there is no alert

[Bug 25748] New: 15.1 - Alerts#getText should raise an error if there is no alert

[Bug 25749] 15.1.1 - clarify if accept or dismiss should be called

[Bug 25749] New: 15.1.1 - clarify if accept or dismiss should be called

[Bug 25751] 15.2 - use "local end" instead of "client end"

[Bug 25751] New: 15.2 - use "local end" instead of "client end"

[Bug 25755] 15.2 - typo "Model" -> "Modal"

[Bug 25755] New: 15.2 - typo "Model" -> "Modal"

[Bug 25756] New: 14.3.3 - Meta and Command aren't considered as modifier keys

[Bug 25941] getCssValue isn't defined by the spec

[Bug 25941] New: getCssValue isn't defined by the spec

[Bug 26031] New: 10.4.1: getElementText does not take into account CSS generated content

[Bug 26091] getTitle is not defined by the spec

[Bug 26091] New: getTitle is not defined by the spec

[Bug 26092] New: findElement doesn't tell that it should find element only inside current element

[Bug 26096] New: WebDriver#get lacks info about timeouts and situation when there is no selected window

[Bug 26096] WebDriver#get lacks info about timeouts and situation when there is no selected window

[Bug 26130] 10.4 - typos in getCssValue section

[Bug 26130] New: 10.4 - typos in getCssValue section

[Bug 26131] 10.4 - atoms contain a different algorithm from defined for getCssValue

[Bug 26131] New: 10.4 - atoms contain a different algorithm from defined for getCssValue

[Bug 26137] New: [WebDriver Spec]: Algorithm for serializing a result is broken

[Bug 26147] New: Don't conflate attributes and properties in getElementAttribute

[Bug 26151] New: [WebDriver Spec]: 2.6 Simplify JSON wire protocol to use one URL

[Bug 26156] New: Spec missing isEnabled command

[Bug 26156] Spec missing isEnabled command

[Bug 26158] New: JSON serialization of element does not make clear that JSON represents an element

[Bug 26228] [WebDriver Spec] 11.2.1 executeScript doesn't specify how to handle self-recursive objects

[Bug 26228] New: [WebDriver Spec] 11.2.1 executeScript doesn't specify how to handle self-recursive objects

[user input] Spec feedback

[WebDriver Spec]: Should we be pushing the use of vendor prefixes for extensions?

[WebDriver] Fwd: [Bug 24974] New: The distinction between Capabilities and MutableCapabilities is not useful in the context of this spec

[WebDriver]: WindowHandles ID when resizing/positioning the window

Controlling the browser environment/settings

Fwd: Browser Testing and Tools Working Group Extended

Logistics for WebDriver Face to Face in London

Next WebDriver F2F

Registration for the WebDriver F2F on July 7-8

WebDriver F2F Agenda?

WebDriver Test Suite

Working Group Charter

Last message date: Monday, 30 June 2014 22:27:56 UTC