W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2015

Travis CI build failing?

From: Hofmann, Bill <bill.hofmann@dolby.com>
Date: Fri, 23 Oct 2015 08:06:29 +0000
To: "Audio WG (public-audio@w3.org)" <public-audio@w3.org>
Message-ID: <64062547EA367442A557186FFBAD8FD764714070@DLB-XCHPW01.dolby.net>
Not sure what the proper next step is here:

WARNING: We were unable to find a .travis.yml file. This may not be what you
  want. Build will be run with default settings.

Using worker: worker-linux-f25aadab-2.bb.travis-ci.org:travis-linux-2

Could not find .travis.yml, using standard configuration.
Build system information
Build language: ruby
Build image provisioning date and time
Wed Feb  4 18:22:50 UTC 2015
Operating System Details
Distributor ID:    Ubuntu
Description:        Ubuntu 12.04 LTS
Release:               12.04
Codename:        precise
Linux Version
2.6.32-042stab090.5
Cookbooks Version
23bb455 https://github.com/travis-ci/travis-cookbooks/tree/23bb455
GCC version
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

LLVM version
clang version 3.4 (tags/RELEASE_34/final)
Target: x86_64-unknown-linux-gnu
Thread model: posix
Pre-installed Ruby versions
ruby-1.9.3-p551
Pre-installed Node.js versions
v0.10.36
Pre-installed Go versions
1.4.1
Redis version
redis-server 2.8.19
riak version
2.0.2
MongoDB version
MongoDB 2.4.12
CouchDB version
couchdb 1.6.1
Neo4j version
1.9.4
Cassandra version
2.0.9
RabbitMQ Version
3.4.3
ElasticSearch version
1.4.0
Installed Sphinx versions
2.0.10
2.1.9
2.2.6
Default Sphinx version
2.2.6
Installed Firefox version
firefox 31.0esr
PhantomJS version
1.9.8
ant -version
Apache Ant(TM) version 1.8.2 compiled on December 3 2011
mvn -version
Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1; 2014-12-14T17:29:23+00:00)
Maven home: /usr/local/maven
Java version: 1.7.0_76, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-7-oracle/jre
Default locale: en, platform encoding: UTF-8
OS name: "linux", version: "2.6.32-042stab090.5", arch: "amd64", family: "unix"

$ git clone --depth=50 --branch=34-audio-element-prose2 https://github.com/WebAudio/web-audio-api.git WebAudio/web-audio-api
Cloning into 'WebAudio/web-audio-api'...
remote: Counting objects: 1131, done.
remote: Compressing objects: 100% (517/517), done.
remote: Total 1131 (delta 667), reused 1066 (delta 608), pack-reused 0
Receiving objects: 100% (1131/1131), 5.52 MiB | 0 bytes/s, done.
Resolving deltas: 100% (667/667), done.
Checking connectivity... done.
$ cd WebAudio/web-audio-api
$ git checkout -qf 45496c0137f57babb425c6b9e97fe1121062aa6a
$ rvm use default
Using /home/travis/.rvm/gems/ruby-1.9.3-p551
$ ruby --version
ruby 1.9.3p551 (2014-11-13 revision 48407) [x86_64-linux]
$ rvm --version
rvm 1.26.10 (latest-minor) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]
$ bundle --version
Bundler version 1.7.6
$ gem --version
2.4.5
$ rake
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)
/home/travis/.rvm/gems/ruby-1.9.3-p551/bin/ruby_executable_hooks:15:in `eval'
/home/travis/.rvm/gems/ruby-1.9.3-p551/bin/ruby_executable_hooks:15:in `<main>'
(See full trace by running task with --trace)

The command "rake" exited with 1.

Done. Your build exited with 1.

Bill Hofmann
E-Media Architecture Team
Dolby Laboratories, Inc.
M: +1 (510) 387-0952
Received on Friday, 23 October 2015 08:06:57 UTC

This archive was generated by hypermail 2.3.1 : Friday, 18 December 2015 09:00:35 UTC